summaryrefslogtreecommitdiff
path: root/dev-libs/grantlee/grantlee-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/grantlee/grantlee-5.1.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/grantlee/grantlee-5.1.0.ebuild')
-rw-r--r--dev-libs/grantlee/grantlee-5.1.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/grantlee/grantlee-5.1.0.ebuild b/dev-libs/grantlee/grantlee-5.1.0.ebuild
deleted file mode 100644
index 553658e457e5..000000000000
--- a/dev-libs/grantlee/grantlee-5.1.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VIRTUALX_REQUIRED="test"
-inherit cmake-utils virtualx
-
-DESCRIPTION="C++ string template engine based on the Django template system"
-HOMEPAGE="https://github.com/steveire/grantlee"
-SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="5"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-IUSE="debug doc test"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtscript:5
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- test? ( dev-qt/qttest:5 )
-"
-
-DOCS=( AUTHORS CHANGELOG README.md )
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
- "${FILESDIR}/${PN}-5.1.0-slot.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- use doc && cmake-utils_src_compile docs
-}
-
-src_test() {
- virtx cmake-utils_src_test
-}
-
-src_install() {
- use doc && HTML_DOCS=("${BUILD_DIR}/apidox/")
-
- cmake-utils_src_install
-}