summaryrefslogtreecommitdiff
path: root/dev-libs/granite/granite-6.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-libs/granite/granite-6.2.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-libs/granite/granite-6.2.0.ebuild')
-rw-r--r--dev-libs/granite/granite-6.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/granite/granite-6.2.0.ebuild b/dev-libs/granite/granite-6.2.0.ebuild
new file mode 100644
index 000000000000..2f782968adcf
--- /dev/null
+++ b/dev-libs/granite/granite-6.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION=0.40
+BUILD_DIR="${WORKDIR}/${P}-build"
+
+inherit meson vala xdg
+
+DESCRIPTION="Elementary OS library that extends GTK+"
+HOMEPAGE="https://github.com/elementary/granite"
+SRC_URI="https://github.com/elementary/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+
+BDEPEND="
+ $(vala_depend)
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ dev-libs/libgee:0.8[introspection]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ vala_src_prepare
+}
+
+src_configure() {
+ # docs disabled due to: https://github.com/elementary/granite/issues/482
+ local emesonargs=(
+ -Ddocumentation=false
+ )
+ meson_src_configure
+}