summaryrefslogtreecommitdiff
path: root/dev-libs/gom/gom-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-libs/gom/gom-0.3.3.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-libs/gom/gom-0.3.3.ebuild')
-rw-r--r--dev-libs/gom/gom-0.3.3.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-libs/gom/gom-0.3.3.ebuild b/dev-libs/gom/gom-0.3.3.ebuild
deleted file mode 100644
index 5d6e936cc3a9..000000000000
--- a/dev-libs/gom/gom-0.3.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-GCONF_DEBUG="yes"
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit gnome.org gnome2-utils meson python-r1
-
-DESCRIPTION="GObject to SQLite object mapper library"
-HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="gtk-doc +introspection test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# <glib-2.63.3 to avoid getting hit worse by https://gitlab.gnome.org/GNOME/gom/issues/24 - fixed in gom-0.4
-RDEPEND="
- >=dev-db/sqlite-3.7:3
- >=dev-libs/glib-2.36:2
- <dev-libs/glib-2.63.3:2
- introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
- ${PYTHON_DEPS}
- >=dev-python/pygobject-3.16:3[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- gtk-doc? ( dev-util/gtk-doc )
- virtual/pkgconfig
- x11-libs/gdk-pixbuf:2
-" # only tests need gdk-pixbuf, but they are unconditionally built
-
-pkg_setup() {
- python_setup
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use introspection enable-introspection)
- $(meson_use gtk-doc enable-gtk-doc)
- )
-
- python_foreach_impl meson_src_configure
-}
-
-src_compile() {
- python_foreach_impl meson_src_compile
-}
-
-src_install() {
- docinto examples
- dodoc examples/*.py
-
- installing() {
- meson_src_install
- python_optimize
- }
- python_foreach_impl installing
-}
-
-src_test() {
- # tests may take a long time
- python_foreach_impl meson_src_test
-}