summaryrefslogtreecommitdiff
path: root/dev-libs/gom/gom-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-libs/gom/gom-0.3.3.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-libs/gom/gom-0.3.3.ebuild')
-rw-r--r--dev-libs/gom/gom-0.3.3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/gom/gom-0.3.3.ebuild b/dev-libs/gom/gom-0.3.3.ebuild
index 146fe47ed507..5d6e936cc3a9 100644
--- a/dev-libs/gom/gom-0.3.3.ebuild
+++ b/dev-libs/gom/gom-0.3.3.ebuild
@@ -13,24 +13,24 @@ HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc +introspection test"
+IUSE="gtk-doc +introspection test"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# <glib-2.63.3 to avoid getting hit worse by https://gitlab.gnome.org/GNOME/gom/issues/24 - fixed in gom-0.4
RDEPEND="
>=dev-db/sqlite-3.7:3
>=dev-libs/glib-2.36:2
+ <dev-libs/glib-2.63.3:2
introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
${PYTHON_DEPS}
>=dev-python/pygobject-3.16:3[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- >=dev-util/intltool-0.40.0
- sys-devel/gettext
+ gtk-doc? ( dev-util/gtk-doc )
virtual/pkgconfig
x11-libs/gdk-pixbuf:2
-"
+" # only tests need gdk-pixbuf, but they are unconditionally built
pkg_setup() {
python_setup
@@ -39,7 +39,7 @@ pkg_setup() {
src_configure() {
local emesonargs=(
$(meson_use introspection enable-introspection)
- $(meson_use doc enable-gtk-doc)
+ $(meson_use gtk-doc enable-gtk-doc)
)
python_foreach_impl meson_src_configure