summaryrefslogtreecommitdiff
path: root/dev-libs/gobject-introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 04:32:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 04:32:23 +0100
commite7bc5cacb1abeb6806d255e2a817ab4dcb5f52b8 (patch)
tree10e07d38ebd7f99316a36d811796804a18fb2697 /dev-libs/gobject-introspection
parent07e5258263817a33e6c141c7f2626f909688bdb1 (diff)
gentoo auto-resync : 09:09:2023 - 04:32:23
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/Manifest2
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.78.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/Manifest b/dev-libs/gobject-introspection/Manifest
index c85de19753ad..662c6501fe70 100644
--- a/dev-libs/gobject-introspection/Manifest
+++ b/dev-libs/gobject-introspection/Manifest
@@ -1,3 +1,5 @@
DIST gobject-introspection-1.76.1.tar.xz 1055416 BLAKE2B 2251c34b543c95f95bdec6853c8234db1b2e6271e729eaa5abf28e39c7718b326e0813a1214c62fb4634fd11218c4c856e6651de09081b01c9fcf8f73b8cf316 SHA512 84331a30f8854d2259609650c21aadd6363ea1417a75828bd395f8f4346da1c6d6550cff5f2c9f5f6fd6fbf2a9d27b5880c2ee1616fa905c5f362384d481a916
+DIST gobject-introspection-1.78.0.tar.xz 1060136 BLAKE2B ae95ad5cec48f0eb001e1ba65cd6e88ab8846d1ab6721ac421f6077f1a69fca1989a0631a7c852361d4b92f7f25503e3f505e734055d3f61530f829924f37972 SHA512 b7749295437255d45f5f842195315105d7b85bddb20bf205c7bd7f0c9e9e77fe1db2c84af6d784b54fb0d8eef488895f5eb9439ccf4ca81d03e802802b13e5dd
EBUILD gobject-introspection-1.76.1.ebuild 1954 BLAKE2B baa9b31ca11fae98afbf76bd4ddeb97a8b87528ea699fbb919529991cf734c9809262683b5689f01df7d2e4ab50a130d0f43cfb5c1e9e917a8fcef3d89000c7a SHA512 bc276845bb8b359d6eb93c4f1acb411e0c8f7ca96350b531e684c7382e7350b6e7bc060df203cba11b9a3adf09b3f5e119021295a9ef87fb04995a5170710444
+EBUILD gobject-introspection-1.78.0.ebuild 1982 BLAKE2B eb8e1f87ac337539a63322d2d0e8f8966a809daa2f6a5d3a3414966b733329bbcff67a8635b950859af9a04bc22137cf817e97f6ea09e70cf21b198910d18486 SHA512 5bb479bf9553ddad0e98acd1265669b6938e09ac40eee1bbd383430463492b9853476d523c94ed10bd1aa52145f1f0a86404d0940c91de4170ebab62571387bf
MISC metadata.xml 485 BLAKE2B 6ecc9396bcb29a8365be4058592c307ddcb0cc16ab56723ca32a378b5608b86378ab291345a6a3ccbe8225c6ffc91b6ba1e2996b5b0d1f4271d0757bf376ef8e SHA512 43a479854b1d5783c028ecfd8357a632db089f95de9e703608de7f229a37beee5e43781ff3f68b2dfa9bceac1355597373d31d209fdea0301917be5fbe7e7fbe
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.78.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.78.0.ebuild
new file mode 100644
index 000000000000..56ef5420626c
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.78.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+inherit gnome.org meson python-single-r1 xdg
+
+DESCRIPTION="Introspection system for GObject-based libraries"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+IUSE="doctool gtk-doc test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# virtual/pkgconfig needed at runtime, bug #505408
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.$(($(ver_cut 2) - 1)).0:2
+ dev-libs/libffi:=
+ doctool? (
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ ')
+ )
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+# Wants real bison, not app-alternatives/yacc
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.19
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xml-dtd:4.5
+ )
+ sys-devel/bison
+ sys-devel/flex
+ test? (
+ x11-libs/cairo[glib]
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test cairo)
+ $(meson_feature doctool)
+ #-Dglib_src_dir
+ $(meson_use gtk-doc gtk_doc)
+ #-Dcairo_libname
+ -Dpython="${EPYTHON}"
+ #-Dgir_dir_prefix
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/
+ python_optimize "${ED}"/usr/$(get_libdir)/gobject-introspection/giscanner
+
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"/usr/share/aclocal/introspection.m4 \
+ "${ED}"/usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"/usr/share/aclocal || die
+}