summaryrefslogtreecommitdiff
path: root/dev-libs/gobject-introspection-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/gobject-introspection-common
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/gobject-introspection-common')
-rw-r--r--dev-libs/gobject-introspection-common/Manifest2
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.58.3.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/Manifest b/dev-libs/gobject-introspection-common/Manifest
index 6c291e15d72e..ae2f14cf22a5 100644
--- a/dev-libs/gobject-introspection-common/Manifest
+++ b/dev-libs/gobject-introspection-common/Manifest
@@ -1,3 +1,5 @@
DIST gobject-introspection-1.56.1.tar.xz 1397812 BLAKE2B 070597f3bd6e4e58d1ae1964cf6e8d7881daa68aeeddc5e9b64bc410fad6d435f2041171f4dfc2a6b477d39f2d7e9181b9917d1244fcb45b3a37491726381649 SHA512 2bfcd45b8c5ad68a3f6550c2f80a6804db0e1a72ffaf4fdd3cec3d8acc23e79ad14bb5bf612fe26fc896691839ab19ca8dd1c9994db14d730e56fa79df9d973d
+DIST gobject-introspection-1.58.3.tar.xz 1378068 BLAKE2B 3ae0328892da30aeefcfb8f6d343312d4967345cc202ef137f29690fbd7a35fa9310f87b134fbdfd4fd753b68b47203cd306689d9892eccf17e303d1e7bcccd4 SHA512 0811cd08e224975b3aa55ae89d648fc65f3105cae8a077a5671593d84743b1db28e9fbffe53fc86a2b3e82ea98c35f3daae033d3df07c7020cc3bf8b5d94f796
EBUILD gobject-introspection-common-1.56.1.ebuild 1019 BLAKE2B 8f1d42b739389066c17614960bc214c616a9717d51e845b98ff0dc59fc10d484bda878a4149b358615568544d5b05259e2a788dce281bd4d5a70fe590373f4ea SHA512 db776369d3eb5af2c664aad6bd52a19f3d0371f9b84221c9cf65359cb625089e54b9b1aa9e3cf926b250fcd89e303a7fcffb34c0e5c58893583c82237a0c16f2
+EBUILD gobject-introspection-common-1.58.3.ebuild 1030 BLAKE2B 5218b44c2b33f827ef1938baee886673372f1c549cb825fd828ccd985c5359297c29bdaae0f77e75a7abd968334f862d27ae63e73796cfce0b59078610ca2600 SHA512 69b3785d707c2ea62c8816961adba2d8e7022983a421c102d9eb46b34f0859fc4b0093eddd009c41e6c02988fbcbaf80102f968202a5c5e79276dfb927bb87ef
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.58.3.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.58.3.ebuild
new file mode 100644
index 000000000000..27b259c27b3d
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.58.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${PN/-common}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/aclocal
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ dodir /usr/share/gobject-introspection-1.0
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}