summaryrefslogtreecommitdiff
path: root/dev-libs/go-fuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/go-fuse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/go-fuse')
-rw-r--r--dev-libs/go-fuse/Manifest6
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild58
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20150422.ebuild55
-rw-r--r--dev-libs/go-fuse/go-fuse-9999.ebuild55
-rw-r--r--dev-libs/go-fuse/metadata.xml11
5 files changed, 185 insertions, 0 deletions
diff --git a/dev-libs/go-fuse/Manifest b/dev-libs/go-fuse/Manifest
new file mode 100644
index 000000000000..1f655bb164bb
--- /dev/null
+++ b/dev-libs/go-fuse/Manifest
@@ -0,0 +1,6 @@
+DIST go-fuse-0_p20140812.tar.gz 111389 BLAKE2B 13cc74fb8844b0486e593ab62e5564111d0a01361edfb3be4c8b0ae3bc298d0043ad80a33318a407236e74f0d9bcea2f87ba4681db4d34ad8818a32b8fa0e459 SHA512 d951094e290bc914b418c165106368d6b73634ffb177b770ce53baaca4cd6026967f11d602b3e687e59a49323c7af1af74913ec1a911093e4e32503025842cb3
+DIST go-fuse-0_p20150422.tar.gz 110741 BLAKE2B 4c01af2a86a97ea9d0309066bc032aa41847b74edc18bc91483fbc789e143f297c90c7fe89f7c376ec0f12859d337a271122884bab79b4e9a94f95bacb63e426 SHA512 a0c9fa666ab39632db258baa5bf6ba1546aa847beb0d4a4b812a96e66d8573e3c0a0600ad24e16e314fbd8082b36027a3e1bc2092667766f611b1321aaea70c5
+EBUILD go-fuse-0_p20140812-r1.ebuild 1379 BLAKE2B ba788c52241655fc72a0bf5646d656410cb10936a3f9e6873a78e98c01107f275d4d3338cc4dc89d8544ecdbca3a04674e462310b579a919610a9c8fe2b8e7f5 SHA512 5605e07f718424b11adbd14907cb371b6c203565542731aedcaa647cc82fb6b706aed51c09766ae98cbf9a289f074d10b63392efb76783a0accc295b48afb72c
+EBUILD go-fuse-0_p20150422.ebuild 1175 BLAKE2B 36c74448cdb232be840afc69bf07ab909468ea1229c01e09e79da749b4722604be7209c0fc284f4733826896b818098f245ea2e6c8b8ab4d0a71a3ae475a4d0a SHA512 501d9403f7505622b1c6671db51d7c7ad2e417d30d3de68adfe9c6c2d04ddb67b6f3457fab94f4180f6b8d1794fbbc5ddd0d1e2b535ba73272ba9e9e53510a90
+EBUILD go-fuse-9999.ebuild 1266 BLAKE2B 863b8fcbdee31d71dc5ad97be41f62df5142cc63f6fc60f068679e9eadf82ba381a5fd5a869243402fe5933f2883228391450a12479776b4dcc3bd1b008c88fc SHA512 34ad9860ee72c0a8555be7c232eb3526923326ac1328536cbe1040ac42825a107a82dad06b32eec93dcfda15cc4db1868f5dee8964eca10a3d00fae9d8c9734e
+MISC metadata.xml 336 BLAKE2B de18fba9c2787705a6a3589ee62ac0147e67b24717499e2b2072a876e44b7529c7ddbd8ac238b6f13d0e1170b608d5de19bb9715825b333f771fc3b29aea21a9 SHA512 d8919ea0b18f378d1dfcae8879976485da1fe27d700fbad0006a9e835a4e87ddae1e91703be9d6ec6d8232737049805f57adf93d9cebbe64c7ad82bf1fed7373
diff --git a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
new file mode 100644
index 000000000000..b697e9c46d3b
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+GO_PN=github.com/hanwen/${PN}
+EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
+
+HOMEPAGE="https://${GO_PN}"
+DESCRIPTION="FUSE bindings for Go"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.3"
+RDEPEND=""
+
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_prepare() {
+ sed -e "s:\(go \${target}\)\(.*\)$:\\1 -x \\2:" \
+ -e 's:^for target in "clean" "install" ; do$:for target in "install" ; do:' \
+ -e '17,26d' \
+ src/${GO_PN}/all.bash > src/${GO_PN}/all.bash.patched || die
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-fuse, for bug #503324.
+ cp -sR /usr/lib/go goroot || die
+ rm -rf goroot/src/${GO_PN} || die
+ rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
+ CGO_CFLAGS="${CFLAGS}" GOROOT="${WORKDIR}/goroot" GOPATH="${WORKDIR}" \
+ bash src/${GO_PN}/all.bash.patched || die
+}
+
+src_install() {
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg
+ insinto /usr/lib/go/src
+ rm src/${GO_PN}/all.bash.patched || die
+ egit_clean src/${GO_PN}
+ doins -r src/*
+}
diff --git a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
new file mode 100644
index 000000000000..894c8c631d8b
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+GO_PN=github.com/hanwen/${PN}
+EGIT_COMMIT="ffed29ec8b88f61c1b8954134cc48ef03bb26ce1"
+
+HOMEPAGE="https://${GO_PN}"
+DESCRIPTION="FUSE bindings for Go"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.3"
+RDEPEND=""
+
+RESTRICT="strip"
+
+src_unpack() {
+ default_src_unpack
+ mkdir -p "${S}/src/${GO_PN%/*}" || die
+ mv ${PN}-${EGIT_COMMIT} "${S}/src/${GO_PN}" || die
+ egit_clean
+}
+
+call_go() {
+ local d
+ for d in fuse fuse/pathfs zipfs unionfs; do
+ GOROOT="${GOROOT}" GOPATH="${S}" \
+ go "${1}" -v -x -work ${GO_PN}/${d} || die
+ done
+}
+
+src_compile() {
+ # Create a filtered GOROOT tree out of symlinks,
+ # excluding go-fuse, for bug #503324.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR /usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" || die
+ rm -rf "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
+ call_go build
+}
+
+src_install() {
+ call_go install
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ insinto /usr/lib/go
+ doins -r pkg src
+}
diff --git a/dev-libs/go-fuse/go-fuse-9999.ebuild b/dev-libs/go-fuse/go-fuse-9999.ebuild
new file mode 100644
index 000000000000..2627a21a5a42
--- /dev/null
+++ b/dev-libs/go-fuse/go-fuse-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit git-r3
+
+DESCRIPTION="native bindings for the FUSE kernel module"
+HOMEPAGE="https://github.com/hanwen/go-fuse"
+EGIT_REPO_URI="https://github.com/hanwen/go-fuse.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.3"
+RDEPEND=""
+
+RESTRICT="strip"
+
+GO_PN="github.com/hanwen/${PN}"
+EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+
+export GOPATH="${S}"
+
+src_compile() {
+ local d
+#no examples right now
+# example/hello example/loopback example/zipfs \
+# example/multizip example/unionfs example/memfs \
+# example/autounionfs ; \
+#or tests
+#fuse/test
+ for d in fuse fuse/pathfs zipfs unionfs; do
+ go build -v -x -work ${GO_PN}/${d} || die
+ done
+}
+
+src_install() {
+ local d
+ for d in fuse fuse/pathfs zipfs unionfs; do
+ go install -v -x -work ${GO_PN}/${d} || die
+ done
+
+ insinto /usr/lib/go/
+ doins -r "${S}/pkg"
+ insinto "/usr/lib/go/src/${GO_PN}/"
+ #for this ebuild, to fix bug #503324 I have limited what is installed
+ #another possible solution would have been using adddeny to the
+ #hide installed filed during build
+ egit_clean "${S}/src/${GO_PN}"
+ doins -r "${S}/src/${GO_PN}/fuse"
+ doins -r "${S}/src/${GO_PN}/splice"
+}
diff --git a/dev-libs/go-fuse/metadata.xml b/dev-libs/go-fuse/metadata.xml
new file mode 100644
index 000000000000..90487b3d8399
--- /dev/null
+++ b/dev-libs/go-fuse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hanwen/go-fuse</remote-id>
+ </upstream>
+</pkgmetadata>