summaryrefslogtreecommitdiff
path: root/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild')
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
deleted file mode 100644
index b697e9c46d3b..000000000000
--- a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-GO_PN=github.com/hanwen/${PN}
-EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
-
-HOMEPAGE="https://${GO_PN}"
-DESCRIPTION="FUSE bindings for Go"
-SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=">=dev-lang/go-1.3"
-RDEPEND=""
-
-RESTRICT="strip"
-
-S=${WORKDIR}
-
-src_unpack() {
- default_src_unpack
- mkdir -p src/${GO_PN%/*} || die
- mv ${PN}-${EGIT_COMMIT} src/${GO_PN} || die
-}
-
-src_prepare() {
- sed -e "s:\(go \${target}\)\(.*\)$:\\1 -x \\2:" \
- -e 's:^for target in "clean" "install" ; do$:for target in "install" ; do:' \
- -e '17,26d' \
- src/${GO_PN}/all.bash > src/${GO_PN}/all.bash.patched || die
-}
-
-src_compile() {
- # Create a filtered GOROOT tree out of symlinks,
- # excluding go-fuse, for bug #503324.
- cp -sR /usr/lib/go goroot || die
- rm -rf goroot/src/${GO_PN} || die
- rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
- CGO_CFLAGS="${CFLAGS}" GOROOT="${WORKDIR}/goroot" GOPATH="${WORKDIR}" \
- bash src/${GO_PN}/all.bash.patched || die
-}
-
-src_install() {
- insopts -m0644 -p # preserve timestamps for bug 551486
- insinto /usr/lib/go
- doins -r pkg
- insinto /usr/lib/go/src
- rm src/${GO_PN}/all.bash.patched || die
- egit_clean src/${GO_PN}
- doins -r src/*
-}