summaryrefslogtreecommitdiff
path: root/dev-libs/gmp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 15:10:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 15:10:46 +0000
commitee8ad1509f726e8fa598472117e5bbffd241ebab (patch)
tree4ac9a10ae4694145a7287533143f85af923c1954 /dev-libs/gmp
parent1fe7aef6facf013a94eac853717f4da4d5d3c5b3 (diff)
gentoo auto-resync : 06:12:2022 - 15:10:45
Diffstat (limited to 'dev-libs/gmp')
-rw-r--r--dev-libs/gmp/Manifest2
-rw-r--r--dev-libs/gmp/gmp-6.2.1-r5.ebuild (renamed from dev-libs/gmp/gmp-6.2.1-r4.ebuild)32
2 files changed, 27 insertions, 7 deletions
diff --git a/dev-libs/gmp/Manifest b/dev-libs/gmp/Manifest
index 5517d56f2b6a..14b7f9628e23 100644
--- a/dev-libs/gmp/Manifest
+++ b/dev-libs/gmp/Manifest
@@ -6,5 +6,5 @@ DIST gmp-6.2.1-arm64-darwin.patch.bz2 2520 BLAKE2B 3d4e9dbd29dc9aa81f0c9e0de4a59
DIST gmp-6.2.1.tar.xz 2027316 BLAKE2B c0d85f175392a50cfa01bc6b0a312b235946ad8b4f6f84f6dabd33d7a6f2cc75c9b0e1e33057be07750bfa0145b7c4cf3b6188a5be6ca9d7271ec2276c84ebcb SHA512 c99be0950a1d05a0297d65641dd35b75b74466f7bf03c9e8a99895a3b2f9a0856cd17887738fa51cf7499781b65c049769271cbcb77d057d2e9f1ec52e07dd84
DIST gmp-man-6.2.1.pdf 827583 BLAKE2B 9aa25457a3c488e37cc7d54d825253ab749a3780919570579b319cf607001de50b212ca387b70213abcc5ab428b4525bdb9cd8ae932798a2d7928da98ce3f353 SHA512 f2d9d02e97975355ef490e921fedc94fb7687c3661eec8fa2e94a1622b6e59b17b3879eb3ec1f2df8edac100f727175144d107f4c49c602b773c43bc9e91dbcb
EBUILD gmp-6.2.1-r2.ebuild 3149 BLAKE2B 934cd313c6cd94b3e4347f1a2b1b6e3c871a274617be729ff496e33be72095a8eb61690238285d4d597994ff3e7d88312130e32afa92a5b0e3d7eb34b02fc51d SHA512 213753bd26129c343f32306262d81fade3b9d67e53014c96656979a480e2a81c4d14776081b1aebf3617804a38be45cf49b1ec13aa1f49fa703819be232512a8
-EBUILD gmp-6.2.1-r4.ebuild 4679 BLAKE2B 2ab8598f855678f032681440a04aaeb2ae19fa136ffbfadfaa8c61a5b722247910982284dbbcb02153dbea988e982a46c2502bf899451cd555622cfc14e4e19a SHA512 d86960214180fb0c67565878a07d4230ea013e0ad173ff96803446f00047c5478cb13d1934457cfa11e6ab72f527b53bdda2ea5d8261b54223393fdd73beb24b
+EBUILD gmp-6.2.1-r5.ebuild 5462 BLAKE2B 5a18f8decd27eea8ce546840aedfeadcaaa7fc9c96c2277d3a0cb8a8dd08dd2726b6db2a0b91889f767cf468bf142d957ef5fa4f12e69549931e8abccdac35a6 SHA512 1bcfd15b5e91bc52a4c024c904daddddfd9a47f75a35bda46a6c444d65361326478c1f9a69bb241d643ab9f5fc8fc28b2ce04235877600e821cefbd855ef9aa3
MISC metadata.xml 1044 BLAKE2B b6c7a609f9b8756693ae49f80508e73483145a9f4a8e3e63f25bdeb53dec0bca9851415f097722b1d646d57ae444fe4fdb98aef83d8a7cb15068672322dd5279 SHA512 4e47e1b850637db4b9d62d3a355587679cda1f245fcd264c6399fd4c463b0efbb2ec29cb4845efdb0795ba1dfa0dbc4c2186e983c6648352c9b41d871f388580
diff --git a/dev-libs/gmp/gmp-6.2.1-r4.ebuild b/dev-libs/gmp/gmp-6.2.1-r5.ebuild
index 0a58fc8ba3b4..2e867d0047e9 100644
--- a/dev-libs/gmp/gmp-6.2.1-r4.ebuild
+++ b/dev-libs/gmp/gmp-6.2.1-r5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit libtool multilib-minimal toolchain-funcs
+inherit gnuconfig libtool multilib-minimal toolchain-funcs
MY_PV=${PV/_p*}
MY_PV=${MY_PV/_/-}
@@ -47,6 +47,14 @@ PATCHES=(
"${FILESDIR}"/${P}-CVE-2021-43618.patch
)
+pkg_pretend() {
+ if use cpudetection && ! use amd64 && ! use x86 ; then
+ elog "Using generic C implementation on non-amd64/x86 with USE=cpudetection"
+ elog "--enable-fat is a no-op on alternative arches."
+ elog "To obtain an optimized build, set USE=-cpudetection, but binpkgs should not then be made."
+ fi
+}
+
src_prepare() {
default
@@ -68,6 +76,19 @@ src_prepare() {
# Patches to original configure might have lost the +x bit.
chmod a+rx configure{,.wrapped} || die
+
+ # Save the upstream files named config.{guess,sub} which are
+ # wrappers around the gnuconfig versions.
+ mkdir "${T}"/gmp-gnuconfig || die
+ mv config.guess "${T}"/gmp-gnuconfig/config.guess || die
+ mv config.sub "${T}"/gmp-gnuconfig/config.sub || die
+ # Grab fresh copies from gnuconfig.
+ touch config.guess config.sub || die
+ gnuconfig_update
+ # Rename the fresh copies to the filenames the wrappers from GMP
+ # expect.
+ mv config.guess configfsf.guess || die
+ mv config.sub configfsf.sub || die
}
multilib_src_configure() {
@@ -115,11 +136,9 @@ multilib_src_configure() {
$(use pic && echo --with-pic)
)
- if use cpudetection && ! use amd64 && ! use x86 ; then
- elog "Using generic C implementation on non-amd64/x86 with USE=cpudetection"
- elog "--enable-fat is a no-op on alternative arches."
- elog "To obtain an optimized build, set USE=-cpudetection, but binpkgs should not then be made."
- fi
+ # Move the wrappers from GMP back into place (may have been destroyed by previous econf run)
+ cp "${T}"/gmp-gnuconfig/config.guess "${S}"/config.guess || die
+ cp "${T}"/gmp-gnuconfig/config.sub "${S}"/config.sub || die
# See bug #883201 again.
if ! use cpudetection && ! tc-is-cross-compiler ; then
@@ -131,6 +150,7 @@ multilib_src_configure() {
einfo "GMP guessed processor type: ${gmp_host}"
ewarn "This build will only work on this machine. Enable USE=cpudetection for binary packages!"
+ export ac_cv_build="${gmp_host}"
export ac_cv_host="${gmp_host}"
fi