summaryrefslogtreecommitdiff
path: root/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/gf-complete/gf-complete-0.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/gf-complete/gf-complete-0.0.0.ebuild')
-rw-r--r--dev-libs/gf-complete/gf-complete-0.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/gf-complete/gf-complete-0.0.0.ebuild b/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
new file mode 100644
index 000000000000..473aba33e2fb
--- /dev/null
+++ b/dev-libs/gf-complete/gf-complete-0.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A Comprehensive Open Source Library for Galois Field Arithmetic"
+HOMEPAGE="http://jerasure.org/"
+SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/${P}.tar.gz"
+S="${WORKDIR}/${PN}.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/ -O3 $(SIMD_FLAGS)//g' src/Makefile.am tools/Makefile.am test/Makefile.am examples/Makefile.am|| die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}