summaryrefslogtreecommitdiff
path: root/dev-libs/fstrm/fstrm-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-libs/fstrm/fstrm-0.6.1.ebuild
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-libs/fstrm/fstrm-0.6.1.ebuild')
-rw-r--r--dev-libs/fstrm/fstrm-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/fstrm/fstrm-0.6.1.ebuild b/dev-libs/fstrm/fstrm-0.6.1.ebuild
new file mode 100644
index 000000000000..cc4ed85f22b2
--- /dev/null
+++ b/dev-libs/fstrm/fstrm-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Frame Streams implementation in C"
+HOMEPAGE="https://github.com/farsightsec/fstrm"
+SRC_URI="https://github.com/farsightsec/fstrm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="utils"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="utils? ( dev-libs/libevent:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable utils programs)
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}