summaryrefslogtreecommitdiff
path: root/dev-libs/foma/foma-0.9.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
commita1392efe64137262023d92492396ca9156d22396 (patch)
treede438b2711c7697c4597fb04f07e988586f34233 /dev-libs/foma/foma-0.9.18.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-libs/foma/foma-0.9.18.ebuild')
-rw-r--r--dev-libs/foma/foma-0.9.18.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/foma/foma-0.9.18.ebuild b/dev-libs/foma/foma-0.9.18.ebuild
new file mode 100644
index 000000000000..778896159254
--- /dev/null
+++ b/dev-libs/foma/foma-0.9.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A set of utilities for constructing finite-state automata and transducers"
+HOMEPAGE="https://github.com/mhulden/foma"
+SRC_URI="https://bitbucket.org/mhulden/foma/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/readline:*
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/foma-0.9.18-clean-makefile.patch" )
+
+src_prepare() {
+ default
+
+ # Install to correct libdir
+ sed "s|/lib|/$(get_libdir)|" -i Makefile || die
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ export RANLIB="$(tc-getRANLIB)"
+
+ export CFLAGS="${CFLAGS} -Wl,--as-needed -D_GNU_SOURCE -std=c99 -fvisibility=hidden -fPIC"
+ export FLOOKUPLDFLAGS="${LDFLAGS} libfoma.a -lz"
+ export LDFLAGS="${LDFLAGS} -lreadline -lz -lncurses"
+
+ default
+}
+
+src_install() {
+ emake prefix="${D}"/usr install
+ einstalldocs
+ find "${D}" -name '*.a' -delete || die
+}