summaryrefslogtreecommitdiff
path: root/dev-libs/ffcall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /dev-libs/ffcall
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/Manifest4
-rw-r--r--dev-libs/ffcall/ffcall-2.0.ebuild64
-rw-r--r--dev-libs/ffcall/ffcall-2.1.ebuild2
3 files changed, 2 insertions, 68 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
index 82dfb741b21a..4757f1fddec7 100644
--- a/dev-libs/ffcall/Manifest
+++ b/dev-libs/ffcall/Manifest
@@ -1,5 +1,3 @@
-DIST libffcall-2.0.tar.gz 938605 BLAKE2B 1e6fcae8f1dcaad52ca84d0dcf97f8dde5bb8153244bbb9047dbab5f6a1dade0a00f149507e6bb14225369a7081cadb069d23c8bc7cdcfaec937d7b9d47d08c1 SHA512 d75aa1df97b14692a9137745bae5b24c4d8f739cb1c7f854e7ed47e4a77a49759122abd6b0e445efa56381f47932c13cd21a154b2783649afb9c7a39e73fea04
DIST libffcall-2.1.tar.gz 943235 BLAKE2B ae82663174db084e830b6ff77ceedf8641b3edeb7800952ac4e2772d9033da3e45f46159e6fdae86615dc69fceba39f48d6c75e6cbd41be98f1986fa69d50b3b SHA512 da73375fb45b7d764c06437a517c2a90abf7d5de6afe0a8ca19e6dfafd2a8c7107e39d230ecbc8edfdd5926b16a0c13b7bb9319287047c47de1241b2f6ae805e
-EBUILD ffcall-2.0.ebuild 1486 BLAKE2B 5d10f52e50730d59a1c6923fc04220e9335780279ff38568109585dd190ae26294a60ab70442f0102c44b230629337a1126ce11d7890e374039e383743891b50 SHA512 b3f368154157db13f660a1aa9cb1f7dca813c8d2921f1038b456cf3c15c79a9752eeb219dafc2753ba11e4891e1a47fd66692c76a8d25290b1f2c51102d07eb3
-EBUILD ffcall-2.1.ebuild 1518 BLAKE2B daff4727edc0165745672b06dabb41c7a85d587434817837074ae8bed4a985c7325a6b2c6851c99fb65101be39e5a3f1f333157cc0c80725238b3ce29ca6cdd0 SHA512 203a451fafef3dbefeb9a3a5ad621509bf54ea9299738700ad44efc5bf4a29bf074fc861fdf5b063099f5971ae5cbfd75d05d94403ef56ca0f039c44eac91a99
+EBUILD ffcall-2.1.ebuild 1517 BLAKE2B 0fc1ec51a7bcdbe83541e3b384060a8b370d29b3ccfbf6fa878684aaea5616691a2871a911e10dbdfae3bfb125682e7fb5f542c83eedf5f277fdb6081c399c6c SHA512 0ad442318a572ceb4ab9ca4682c15bdf3a6074a67df3f34ac352fd60c2703485cf801839597bd702db4f45bdb8b76f379140f78fa325b9923c6e9ac85cf8b07e
MISC metadata.xml 858 BLAKE2B a47a659baa99a77ae0caae149918d698ab357a691fd1c57dfe9671ab5631da54b15daaa96fe45b251f800fcb00da5e3c6e87e30eec2bc960301fa6f818cb34da SHA512 e64e471f2fdcc289c678bfc4fe3d2f652062907f9ff18d0350c0907b3d9bfa4e92c76bf04d1b2f0fb3f820f917ec4e3bd7d997a0d5e2eb270ac10516cb58f971
diff --git a/dev-libs/ffcall/ffcall-2.0.ebuild b/dev-libs/ffcall/ffcall-2.0.ebuild
deleted file mode 100644
index c9613431deb4..000000000000
--- a/dev-libs/ffcall/ffcall-2.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PV="libffcall-${PV}"
-
-DESCRIPTION="foreign function call libraries"
-HOMEPAGE="https://www.gnu.org/software/libffcall/"
-SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
-
-# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
-# or in derivate works of GNUstep, the included parts of ffcall are
-# under GNU LGPL." -ffcall author
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm64 ~hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-S=${WORKDIR}/${MY_PV}
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- # The build system is a strange mix of autogenerated
- # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
- # We are adding them consistently here and a bit over the top:
- # bugs: #334581
-
- for mfi in {,*/,*/*/,}Makefile.in
- do
- elog "Patching '${mfi}'"
- # usually uses only assembler here, but -march=
- # and -Wa, are a must to pass here.
- sed -e 's/$(CC) /&$(CFLAGS) /g' \
- -i "${mfi}" || die
- done
- eapply_user
-}
-
-src_configure() {
- append-flags -fPIC
-
- # Doc goes in datadir
- econf \
- --datadir="${EPREFIX}"/usr/share/doc/${PF} \
- --enable-shared \
- --disable-static
-}
-
-src_compile() {
- # TODO. Remove -j1
- emake -j1
-}
-
-src_install() {
- dodoc NEWS README
- dodir /usr/share/man
- default
- prune_libtool_files
-}
diff --git a/dev-libs/ffcall/ffcall-2.1.ebuild b/dev-libs/ffcall/ffcall-2.1.ebuild
index b20e17a0e0d1..f117b8a8f4b4 100644
--- a/dev-libs/ffcall/ffcall-2.1.ebuild
+++ b/dev-libs/ffcall/ffcall-2.1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
# under GNU LGPL." -ffcall author
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 ~arm64 ~hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""
S=${WORKDIR}/${MY_PV}