summaryrefslogtreecommitdiff
path: root/dev-libs/ffcall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-libs/ffcall
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/Manifest2
-rw-r--r--dev-libs/ffcall/ffcall-2.4.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
index 4dcbe577694b..66b14466a951 100644
--- a/dev-libs/ffcall/Manifest
+++ b/dev-libs/ffcall/Manifest
@@ -1,3 +1,5 @@
DIST libffcall-2.1.tar.gz 943235 BLAKE2B ae82663174db084e830b6ff77ceedf8641b3edeb7800952ac4e2772d9033da3e45f46159e6fdae86615dc69fceba39f48d6c75e6cbd41be98f1986fa69d50b3b SHA512 da73375fb45b7d764c06437a517c2a90abf7d5de6afe0a8ca19e6dfafd2a8c7107e39d230ecbc8edfdd5926b16a0c13b7bb9319287047c47de1241b2f6ae805e
+DIST libffcall-2.4.tar.gz 1253767 BLAKE2B 669bf556f082b533eb7d71ebc6fadeac464b1a6054ac8078c9315678929bcfb8ad4b7376b345bcfbb5d2caf9d45179012d4bb5a08ad675f475f58570ae96b7ae SHA512 c9451662764a888e3be21499c29673bfb0e1df4915814da3506db5d395a2b00ea2f0c08d1c9dffebf030179f9347794876ec6ec9e6710b4fc70fd760960335e6
EBUILD ffcall-2.1.ebuild 1466 BLAKE2B 3a18b74e440bdb0d4a4a0d910cb77b6643a3d2f958a9656af5116642b904e650c56f10d93b1fb19f0c2b10bc7bcc1d29517fa0ed20ea42b30ed58f7561f57fa7 SHA512 00df8ef9fc1219e9d0e177d8f48add57d54d30b79fcf1021c12a0d421c47b6570db2a1ff057f11f235661e85579e93ee8aeaad421ba379fb93325bb60a9d9573
+EBUILD ffcall-2.4.ebuild 1483 BLAKE2B f5802d5fb500792c966ece4d9c5fb3b06d9525701108834e681f2a3c149b1ed2cdd868d46ffc8177c03867d4a6f1d3f2f8b29b726f094c178b57e1d2b53ef96d SHA512 d9930c7ec80dbb59143648a04b20444883cc74d7470db0f2305f34cf679856d3d357f1d3d420b16020631ef668c2c01f3b09739b8d2dabbd4d095948c07420c4
MISC metadata.xml 859 BLAKE2B a3c2244f2545985f3000c06357c8494bda02e082d089a1b44793a944bdd2592eac8b6e567be29943d07a0eb2930dfda1eb20695f213ec469a1457fd3f8d4360f SHA512 49e8a58e4839ee6d15de7165fede7f8b5f1f200731f8d3a0c4ceee97b8ff1c6e03550ca6be6531d928d43000ec7ded5922f85ef8e3a97d1853be94c9c3d3afe0
diff --git a/dev-libs/ffcall/ffcall-2.4.ebuild b/dev-libs/ffcall/ffcall-2.4.ebuild
new file mode 100644
index 000000000000..84fa806a52d6
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+MY_PV="libffcall-${PV}"
+
+DESCRIPTION="Build foreign function call interfaces in embedded interpreter"
+HOMEPAGE="https://www.gnu.org/software/libffcall/"
+SRC_URI="mirror://gnu/libffcall/${MY_PV}.tar.gz"
+S="${WORKDIR}"/${MY_PV}
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+src_prepare() {
+ # The build system is a strange mix of autogenerated
+ # files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
+ # We are adding them consistently here and a bit over the top:
+ # bugs: #334581
+ local mfi
+ for mfi in {,*/,*/*/,}Makefile.in ; do
+ einfo "Patching '${mfi}'"
+ # usually uses only assembler here, but -march=
+ # and -Wa, are a must to pass here.
+ sed -e 's/$(CC) /&$(CFLAGS) /g' \
+ -i "${mfi}" || die
+ done
+
+ eapply_user
+}
+
+src_configure() {
+ append-flags -fPIC
+
+ # Doc goes in datadir
+ econf \
+ --datadir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ --disable-static
+}
+
+src_compile() {
+ # TODO. Remove -j1
+ emake -j1
+}
+
+src_install() {
+ dodoc NEWS README
+ dodir /usr/share/man
+
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}