summaryrefslogtreecommitdiff
path: root/dev-libs/fampp2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/fampp2/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/fampp2/files')
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch78
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch67
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch46
3 files changed, 191 insertions, 0 deletions
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch b/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch
new file mode 100644
index 000000000000..34067ff1f539
--- /dev/null
+++ b/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch
@@ -0,0 +1,78 @@
+Fix buildsystem, to avoid ugly and extremely brittle patching
+of the configure script and Makefile.in in the main ebuild.
+
+--- a/configure.in
++++ b/configure.in
+@@ -1,8 +1,8 @@
++AC_PREREQ([2.69])
++AC_INIT([fampp2],[7.0.1])
+
+-# require autoconf 2.13
+-AC_PREREQ(2.13)
+-
+-AC_INIT(src/Fampp2.hh)
++AC_CONFIG_MACRO_DIR([macros])
++AC_CONFIG_SRCDIR([src/Fampp2.hh])
+
+ FAMPPTWO_MAJOR=7
+ FAMPPTWO_MINOR=0
+@@ -22,9 +22,8 @@
+ VERSION=$FAMPP_VERSION
+ PACKAGE=fampp2
+
+-AM_CONFIG_HEADER(config.h)
+-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+-AM_MAINTAINER_MODE
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE
+
+ AC_CANONICAL_HOST
+ AC_ISC_POSIX
+@@ -33,11 +32,7 @@
+ AC_PROG_CPP
+ AC_PROG_CXX
+
+-AC_STDC_HEADERS
+-#AC_ARG_PROGRAM
+-AC_DISABLE_FAST_INSTALL
+-AC_DISABLE_STATIC
+-AM_PROG_LIBTOOL
++LT_INIT
+
+
+ dnl Checks for libraries.
+@@ -58,15 +53,12 @@
+ ###############################################################################
+
+
+-CFLAGS=" $STLPORT_CFLAGS $LOKI_CFLAGS $SIGC_CFLAGS $CFLAGS -O0 -g "
+-CXXFLAGS=" $STLPORT_CFLAGS $CXXFLAGS -O0 -g $LOKI_LIBS $SIGC_CFLAGS "
+-LDFLAGS=" $STLPORT_LIBS $SIGC_LIBS $LDFLAGS -Wl,-O1 -Wl,--hash-style=both"
+-AC_SUBST(CFLAGS)
+-AC_SUBST(CPPFLAGS)
+-AC_SUBST(LDFLAGS)
+-AC_SUBST(CXXFLAGS)
+-AC_SUBST(CXXCPPFLAGS)
++CFLAGS="${CFLAGS} ${STLPORT_CFLAGS} ${LOKI_CFLAGS} ${SIGC_CFLAGS}"
++CXXFLAGS="${CXXFLAGS} ${STLPORT_CFLAGS} ${LOKI_CFLAGS} ${SIGC_CFLAGS}"
++LIBS="${LIBS} ${STLPORT_LIBS} ${LOKI_LIBS} ${SIGC_LIBS}"
+
++AC_ARG_WITH([examples], [install examples])
++AM_CONDITIONAL([EXAMPLES], [test "x$with_examples" = "xyes"])
+
+ dnl if test "x${prefix}" = 'xNONE'; then
+ dnl prefix=${ac_default_prefix};
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,10 @@
+ AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects
+
+ NULL=
+-SUBDIRS = src examples
++SUBDIRS = src
++if EXAMPLES
++SUBDIRS += examples
++endif
+
+ EXTRA_DIST = fampp.spec fampp.spec.in fampp2.pc.in fampp2.pc
+
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch b/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch
new file mode 100644
index 000000000000..659ecd51bf4c
--- /dev/null
+++ b/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch
@@ -0,0 +1,67 @@
+C++11 changed destructor semantics to be noexcept(true)
+by default, leading to potentially changed semantics.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=595308
+
+--- a/src/Fampp2.cpp
++++ b/src/Fampp2.cpp
+@@ -105,6 +105,9 @@
+ // #include <unistd.h>
+
+ FamppRequest::~FamppRequest()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
+ {
+ // cerr << "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" << endl;
+ // cerr << "FamppRequest::~FamppRequest() this:" << (void*)this << endl;
+@@ -245,6 +248,9 @@
+
+
+ FamppImplMethods::~FamppImplMethods()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
+ {
+ if(0 != FAMClose( &theFAMConnection )) {
+ throw FamppCloseFailedException();
+--- a/src/Fampp2.hh
++++ b/src/Fampp2.hh
+@@ -168,7 +168,11 @@
+ public:
+
+
+- ~FamppRequest();
++ ~FamppRequest()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ ;
+
+
+ void suspend();
+@@ -216,7 +220,11 @@
+ protected:
+
+ FamppImplMethods();
+- virtual ~FamppImplMethods();
++ virtual ~FamppImplMethods()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ ;
+
+
+ public:
+@@ -251,7 +259,11 @@
+ public:
+ FamppSingletonClass();
+ FamppSingletonClass(const std::string appName);
+- ~FamppSingletonClass();
++ ~FamppSingletonClass()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ ;
+
+
+ void NextEvent();
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch b/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch
new file mode 100644
index 000000000000..6b76a1532cbb
--- /dev/null
+++ b/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch
@@ -0,0 +1,46 @@
+Remove inclusion of libsigc++ headers obsoleted with version 2.6
+See also: https://bugs.gentoo.org/show_bug.cgi?id=569700
+
+--- a/examples/console_test/famppct.cpp
++++ b/examples/console_test/famppct.cpp
+@@ -30,8 +30,6 @@
+
+ #include <sigc++/sigc++.h>
+ #include <sigc++/slot.h>
+-#include <sigc++/object.h>
+-#include <sigc++/object_slot.h>
+
+ #include <gtk/gtk.h>
+ #include <stdio.h>
+--- a/examples/gtk/famppgtk.cpp
++++ b/examples/gtk/famppgtk.cpp
+@@ -31,8 +31,6 @@
+
+ #include <sigc++/sigc++.h>
+ #include <sigc++/slot.h>
+-#include <sigc++/object.h>
+-#include <sigc++/object_slot.h>
+
+ #include <gtk/gtk.h>
+ #include <stdio.h>
+--- a/src/Fampp2.cpp
++++ b/src/Fampp2.cpp
+@@ -34,8 +34,6 @@
+
+ #include <sigc++/sigc++.h>
+ #include <sigc++/slot.h>
+-#include <sigc++/object.h>
+-#include <sigc++/object_slot.h>
+
+
+ using namespace std;
+--- a/src/FamppEvents.hh
++++ b/src/FamppEvents.hh
+@@ -36,7 +36,6 @@
+
+ #include <fam.h>
+ #include <sigc++/signal.h>
+-#include <sigc++/object.h>
+ #include <SmartPtr.h>
+ #include <Singleton.h>
+ #include <Factory.h>