summaryrefslogtreecommitdiff
path: root/dev-libs/dqlite/dqlite-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-libs/dqlite/dqlite-1.9.0.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-libs/dqlite/dqlite-1.9.0.ebuild')
-rw-r--r--dev-libs/dqlite/dqlite-1.9.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/dqlite/dqlite-1.9.0.ebuild b/dev-libs/dqlite/dqlite-1.9.0.ebuild
new file mode 100644
index 000000000000..f28db5e9d758
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://dqlite.io/ https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv
+ dev-libs/raft"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/raft-0.11.1[lz4,test] )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-debug
+ --disable-sanitize
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}