summaryrefslogtreecommitdiff
path: root/dev-libs/distorm64
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/distorm64
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/distorm64')
-rw-r--r--dev-libs/distorm64/Manifest5
-rw-r--r--dev-libs/distorm64/distorm64-3.3.3.ebuild26
-rw-r--r--dev-libs/distorm64/distorm64-3.3.4.ebuild26
-rw-r--r--dev-libs/distorm64/metadata.xml19
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/distorm64/Manifest b/dev-libs/distorm64/Manifest
new file mode 100644
index 000000000000..7570d590ad4e
--- /dev/null
+++ b/dev-libs/distorm64/Manifest
@@ -0,0 +1,5 @@
+DIST distorm-3.3.3.tar.gz 220254 BLAKE2B 2f3cad53365d0ba305de0da5c45fdebbecea2eda1428cc370230c9607608fcc4cbfcd3be364f3421db2bf678e1ca9e8501d645fe365275f3a00846e7aa1c8d27 SHA512 abc37d050efcb7fd7c6e0f1ef055537f06059528fb48a07d159621adca8d905ee3a44b394d75e10aa69f2429fb1023e9282b349281acb3a9474148f195306fbf
+DIST distorm-3.3.4.tar.gz 220334 BLAKE2B 6fb534630a43bf7b9c23added8fc8101a6811ea4630b09948e3774b49508f3dd25a7acd1ffb87e0503cf17bd7ce5300053c9196c7dd754094c4a6ee5dbbc430f SHA512 172bb1a9a3f92089daf140fd019c94cf3b63f646b78e7aa527640819f418b1e3df2e2d727a76863a7800e6e3735c404054aeb48fceeec7a94f95480b89883b90
+EBUILD distorm64-3.3.3.ebuild 537 BLAKE2B e864b95ade7fdd827e2d7610ab92c28ebb7206934f697c65a5393e8a888a6d5a91cfd15e769beda06d15e86814fa3e6a9f57cecde88fe253096286ad92c6b2e5 SHA512 19067c36461cf72c0b2823b36d1cfd1c698f99a8fd40c6e9bb32dabb481c9d99b14555e36587a9101ea800b81557e72b21aa5ab86046fae203b36e5ff3e5bf25
+EBUILD distorm64-3.3.4.ebuild 553 BLAKE2B a455d2b011d0e221baaf6e1f1549d5bade4871798a5d677abd2f36954447968d1b616bc7b46972f1db3ec30d9d4a95b3d96d3bf39cd35ecbf7e5bae1147df04a SHA512 f1d673ea1f60797879d6680129833658865a02b5f87a536fe3298a8e147bfbd1fbdf97a80c72909f8b3cfd4bbc97b77a537edb517d79da4975daa81eab632d51
+MISC metadata.xml 541 BLAKE2B 6c2f81faf6c95690ba0ca52f27f9a8dceae7eb3e85690f9f9cb3825ddb9da76e0beddb21c45f7a914f13197857cb4d2701204fbd194a032e102f3703b3bcabae SHA512 264cfb7a150b89d0c84d275466c5dce39631a939523990b728c9c3bd6db7854f0a23ec3403b92c3a8c1fff6c8b436eeb6e1503706008aadde11b7c51834b0b57
diff --git a/dev-libs/distorm64/distorm64-3.3.3.ebuild b/dev-libs/distorm64/distorm64-3.3.3.ebuild
new file mode 100644
index 000000000000..74d0bdc5ef7f
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# does not work with python3_4 as-is
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+MY_PN=distorm
+MY_P=${MY_PN}-${PV}
+
+SRC_URI="https://github.com/gdabah/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-libs/distorm64/distorm64-3.3.4.ebuild b/dev-libs/distorm64/distorm64-3.3.4.ebuild
new file mode 100644
index 000000000000..bdb8f39dca4b
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.3.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# does not work with python3_4 as-is
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+MY_PN=distorm
+MY_P=${MY_PN}-${PV}
+
+SRC_URI="https://github.com/gdabah/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-libs/distorm64/metadata.xml b/dev-libs/distorm64/metadata.xml
new file mode 100644
index 000000000000..a490a1ed469a
--- /dev/null
+++ b/dev-libs/distorm64/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gdabah/distorm</remote-id>
+ </upstream>
+</pkgmetadata>