summaryrefslogtreecommitdiff
path: root/dev-libs/distorm3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-libs/distorm3
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-libs/distorm3')
-rw-r--r--dev-libs/distorm3/Manifest5
-rw-r--r--dev-libs/distorm3/distorm3-3.5.1.ebuild27
-rw-r--r--dev-libs/distorm3/distorm3-3.5.2.ebuild27
-rw-r--r--dev-libs/distorm3/metadata.xml19
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/distorm3/Manifest b/dev-libs/distorm3/Manifest
new file mode 100644
index 000000000000..391e93f55ef0
--- /dev/null
+++ b/dev-libs/distorm3/Manifest
@@ -0,0 +1,5 @@
+DIST distorm3-3.5.1.tar.gz 137638 BLAKE2B cecd29dd30a78514e8f8275fef6d0d8338f8d3f5c22b9b48abf2a156b9dc14626455db92172a9bcf6ce36fab8975149395437697a464ce8dd7fb73e9acfcad9d SHA512 0f4cc669c0c562f8458f29d7d6c5d6c308e4681c1c1737d9d81dd2d02e11e5af236b7084d1b24980d1bd0fac514a043bb83d3b6c499b731d43cb4b7458172c48
+DIST distorm3-3.5.2.tar.gz 138371 BLAKE2B 76cc9c987d53a5c7336632ee96878df62865a862bba9b3d07fa95cd585aff428a0187033b78e0731f14a24cc37d7d19f290b2ca06a5a3dd6ee8116a0e68678c8 SHA512 bc08a12f87e6bf22ff9bbba8a34b88b0988b80ddec405c669ba5cd863545128f8b3df4b122a69f4849af3d08818c836b368332e6546871bdfee99e611b3f8d19
+EBUILD distorm3-3.5.1.ebuild 528 BLAKE2B f3ceacc416b85d7d3a1f6d63f33f6c99e9bf3a555a1e2af47c2f33c8699d7c893099bfb77d27d58ed68377805264ae0f6daa64f2265dd65cea5acafe1dea8e8f SHA512 4f8461ce074820af6b2b0aec5aa1dd12afae2f0636748c4213196b9f50e906a60b487b4e923c6eb6cce00c042c4ea604c4a9c694c1536394d23cb2e7ddc7a3a9
+EBUILD distorm3-3.5.2.ebuild 528 BLAKE2B b554e285b744047f91468cb9a4c0132ca0179cb354251d0d9afda88c2549594cd1361a6bda4dae48ad0b5b15188d8d461b910ef11268177dfd4fcabfa97df466 SHA512 75d186ec72e5c5e873c07fb1c40e276223d349e9a9b7a6bdef0cf0416e6b32f47d1a2da9ac2c3e41ca6dafe156197c777d79157bb97797858be8a054a9638bf2
+MISC metadata.xml 541 BLAKE2B 6c2f81faf6c95690ba0ca52f27f9a8dceae7eb3e85690f9f9cb3825ddb9da76e0beddb21c45f7a914f13197857cb4d2701204fbd194a032e102f3703b3bcabae SHA512 264cfb7a150b89d0c84d275466c5dce39631a939523990b728c9c3bd6db7854f0a23ec3403b92c3a8c1fff6c8b436eeb6e1503706008aadde11b7c51834b0b57
diff --git a/dev-libs/distorm3/distorm3-3.5.1.ebuild b/dev-libs/distorm3/distorm3-3.5.1.ebuild
new file mode 100644
index 000000000000..595dc882599f
--- /dev/null
+++ b/dev-libs/distorm3/distorm3-3.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}
diff --git a/dev-libs/distorm3/distorm3-3.5.2.ebuild b/dev-libs/distorm3/distorm3-3.5.2.ebuild
new file mode 100644
index 000000000000..ca0ec447e8d4
--- /dev/null
+++ b/dev-libs/distorm3/distorm3-3.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+DEPEND=""
+RDEPEND=""
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}
diff --git a/dev-libs/distorm3/metadata.xml b/dev-libs/distorm3/metadata.xml
new file mode 100644
index 000000000000..a490a1ed469a
--- /dev/null
+++ b/dev-libs/distorm3/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gdabah/distorm</remote-id>
+ </upstream>
+</pkgmetadata>