summaryrefslogtreecommitdiff
path: root/dev-libs/device-atlas-api-c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-libs/device-atlas-api-c
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-libs/device-atlas-api-c')
-rw-r--r--dev-libs/device-atlas-api-c/Manifest4
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.4.ebuild48
-rw-r--r--dev-libs/device-atlas-api-c/files/2.1.4-src-cmakelists.patch25
-rw-r--r--dev-libs/device-atlas-api-c/metadata.xml15
4 files changed, 0 insertions, 92 deletions
diff --git a/dev-libs/device-atlas-api-c/Manifest b/dev-libs/device-atlas-api-c/Manifest
deleted file mode 100644
index c1e5e1fe0519..000000000000
--- a/dev-libs/device-atlas-api-c/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX 2.1.4-src-cmakelists.patch 1496 BLAKE2B 879dfb7943eee4c03791c25b1f73d5a1d1cdab07f5144f46891d610492dffd61dfa0cd03afb35177740615549a81ac403d0f4009992cb78d46fccb2f20efe922 SHA512 1f9097accda72d10bf5201110fc5ae099d99e4a6573ac30fac399744b88ce9957f6fa82e8c11275663e028865c8c4b376d07ba8894785b57e8324e6e2ea81f2c
-DIST deviceatlas-enterprise-c-2.1.4.tgz 51756 BLAKE2B f8dafdf31b608890da07214e14e9b2ec558e2c9c94c394a04c554e915cc1d4e2e886be1c0932353b0a68efaf90f190157696a2575db6ff2a86bbca3b492bc427 SHA512 5ea765738560c6dbc90799426f6bc0e6eb5e7775fa005279f046a68a4a984305ef99ae8b943dd9d32f88d88c1d24b6c09145643fa64a90eb834fc4a6ece05008
-EBUILD device-atlas-api-c-2.1.4.ebuild 992 BLAKE2B a82dc8b3f1e78572763a771cd8a59d80c719b6613e1591ed074864512811c0b3e3a5cf84e34a161c5312d7669a686b3072333a6e51d36dcaac1d98a4d91effe5 SHA512 bc9272a8efb0a99008403dc981d662a86800cd92e462a3c9d0c517b0ffb83a19d7a711abc3675a384d23d0a77a4b32b43755c81153bfacbf4ed0ca27d65a6486
-MISC metadata.xml 825 BLAKE2B e89864cd72277384374298687208ed42e2bb73bda2b7674b4bf20324334f6dc0139edcb74f5ceb71818bb40ebfa92e1ef1aaec79c4e339a8f1604dc0bd9c916b SHA512 b3547039be329be3cc8ecc83e311e3910855ac24056ea14f3245dd4749fd2db9cbfdbb94cc2cc9158a8a7115f529c67d24da6932c511bbabb38dced157e1f20e
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.4.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.4.ebuild
deleted file mode 100644
index 1f91f978318a..000000000000
--- a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-CMAKE_MAKEFILE_GENERATOR=emake
-inherit cmake-multilib
-
-MY_P="deviceatlas-enterprise-c-${PV/_p/_}"
-
-DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
-HOMEPAGE="https://deviceatlas.com"
-SRC_URI="${MY_P}.tgz"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="doc examples"
-
-RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
-DEPEND="
- ${RDEPEND}"
-
-RESTRICT="fetch mirror bindist"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-src-cmakelists.patch"
-)
-
-pkg_nofetch() {
- eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
- eerror "And download DeviceAtlas C API"
- eerror "Save the file as ${MY_P}.tgz in your DISTDIR directory."
-}
-
-multilib_src_install_all() {
- if use doc; then
- local -a HTML_DOCS=( Documentation )
- fi
-
- if use examples; then
- docinto examples
- dodoc -r Examples/.
- fi
-
- einstalldocs
-}
diff --git a/dev-libs/device-atlas-api-c/files/2.1.4-src-cmakelists.patch b/dev-libs/device-atlas-api-c/files/2.1.4-src-cmakelists.patch
deleted file mode 100644
index d66fdad8e4dc..000000000000
--- a/dev-libs/device-atlas-api-c/files/2.1.4-src-cmakelists.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/Src/CMakeLists.txt
-+++ b/Src/CMakeLists.txt
-@@ -11,6 +11,7 @@ if (NOT LIBTYPE)
- set(LIBTYPE SHARED)
- endif()
-
-+include(GNUInstallDirs)
- message(STATUS "${CMAKE_BUILD_TYPE} version")
-
- include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
-@@ -33,11 +34,11 @@ set_target_properties(ci PROPERTIES SOVERSION ${CI_API_VERSION})
-
- if(UNIX)
- if(NOT APPLE)
-- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libda.so ${CMAKE_CURRENT_BINARY_DIR}/libda.so.${DA_API_VERSION} DESTINATION /usr/local/lib)
-- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libci.so ${CMAKE_CURRENT_BINARY_DIR}/libci.so.${CI_API_VERSION} DESTINATION /usr/local/lib)
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libda.so ${CMAKE_CURRENT_BINARY_DIR}/libda.so.${DA_API_VERSION} DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libci.so ${CMAKE_CURRENT_BINARY_DIR}/libci.so.${CI_API_VERSION} DESTINATION ${CMAKE_INSTALL_LIBDIR})
- else()
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libda.dylib ${CMAKE_CURRENT_BINARY_DIR}/libda.${DA_API_VERSION}.dylib DESTINATION /usr/local/lib)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libci.dylib ${CMAKE_CURRENT_BINARY_DIR}/libci.${CI_API_VERSION}.dylib DESTINATION /usr/local/lib)
- endif()
-- install(FILES dac.h dac_json.h ci.h ci_priv.h ci_fwd.h DESTINATION /usr/local/include)
-+ install(FILES dac.h dac_json.h ci.h ci_priv.h ci_fwd.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
- endif()
diff --git a/dev-libs/device-atlas-api-c/metadata.xml b/dev-libs/device-atlas-api-c/metadata.xml
deleted file mode 100644
index 715b905568b1..000000000000
--- a/dev-libs/device-atlas-api-c/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>bertrand@jacquin.bzh</email>
- <name>Bertrand Jacquin</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription>
- DeviceAtlas is the de facto standard for device data across the web, telco, advertising and digital marketing sectors. As the only solution that is indexed for both web and mobile operator environments, DeviceAtlas' patented technology provides a common device identifier to understand device traffic across all connected environments.
- </longdescription>
-</pkgmetadata>