summaryrefslogtreecommitdiff
path: root/dev-libs/device-atlas-api-c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/device-atlas-api-c
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/device-atlas-api-c')
-rw-r--r--dev-libs/device-atlas-api-c/Manifest4
-rw-r--r--dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild50
-rw-r--r--dev-libs/device-atlas-api-c/files/2.1.3-src-cmakelists.patch18
-rw-r--r--dev-libs/device-atlas-api-c/metadata.xml15
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/Manifest b/dev-libs/device-atlas-api-c/Manifest
new file mode 100644
index 000000000000..418230c8aebd
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/Manifest
@@ -0,0 +1,4 @@
+AUX 2.1.3-src-cmakelists.patch 629 BLAKE2B f3bb4160bbbe58a92e33216f11b52f25b3fc80d58efd11830575b819a41165df51f3c7e8c1a4c431157296d34f179c95c596b2d37b22b5211ff3e7e05989e671 SHA512 08b5f1156341b91911adbba7d527f11f385642a8afcd0ad0e833f83e6c799dd85bb6195dddf9cde13672ec9f52b5b7094f57a09c85866c3c42e627495b45e9bb
+DIST deviceatlas-enterprise-c-2.1.3.tgz 183663 BLAKE2B e190aa8e9a4b9bc90af76e21eb425c0f040ef70e605c8f9e588bd0c859520a82807aaafddd24402d3365e94bcf3b7a875a65804f2b1b3bed6f0703f28a841440 SHA512 364811d42b2c0d937a12f2bbfee760701a1dee4e93bcc84423c8b236d59257a3440111ffc6072a7822b9694ea65986572550f67d0b1e5d68a784d1339b2b70aa
+EBUILD device-atlas-api-c-2.1.3.ebuild 1054 BLAKE2B 77f2191b854b8364939e6a41e18802d8f7df0d51102d90bf2504e10e3e47d11eecc6f3f2bb3a32f205baa0065bd5c7d68990164233177e139d7b98b7d6cd9ebc SHA512 d0f153771e46878c47ea4887799f703d3d9cbcc6fb2fc5ce96f31ded933ba9982f6de4e7ef881377f5e72cf652b2b8ebdd2b85360ceb7d8772e4c178def2f560
+MISC metadata.xml 794 BLAKE2B 5021d469addcb51164731491a3a9ae1c24c3a24ccf2159574bcd8cb2c3ec7aa5dd217beb093c696db8438ae31778c18f8d047e73deec3984683009f50279af41 SHA512 2da64d528f2e49d368ba7b8684d818f0d8bb979dd0c64d613f25bdca97a9c5a3af2eb85f4955e03ed52dc5eb43b3ba7bad21eb94bdd67d370e1ddfa6545b26a1
diff --git a/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild
new file mode 100644
index 000000000000..4679d064f462
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/device-atlas-api-c-2.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+MY_P="deviceatlas-enterprise-c-${PV/_p/_}"
+
+DESCRIPTION="API to detect devices based on the User-Agent HTTP header"
+HOMEPAGE="https://deviceatlas.com"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libpcre[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}"
+
+RESTRICT="fetch mirror bindist"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-src-cmakelists.patch"
+)
+
+pkg_nofetch() {
+ eerror "Please go to https://deviceatlas.com/deviceatlas-haproxy-module"
+ eerror "And download DeviceAtlas C API"
+ eerror "Then place the file in ${DISTDIR}/${MY_P}.tgz"
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local -a HTML_DOCS=( Documentation )
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc Examples/daexutil.h
+ dodoc Examples/example{0,1,2,3,4}.c
+ dodoc Examples/util.c
+ dodoc Examples/EXAMPLES.USAGE
+ fi
+
+ einstalldocs
+}
diff --git a/dev-libs/device-atlas-api-c/files/2.1.3-src-cmakelists.patch b/dev-libs/device-atlas-api-c/files/2.1.3-src-cmakelists.patch
new file mode 100644
index 000000000000..6d1f9ff5586b
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/files/2.1.3-src-cmakelists.patch
@@ -0,0 +1,18 @@
+--- a/Src/CMakeLists.txt
++++ b/Src/CMakeLists.txt
+@@ -18,6 +18,7 @@ if (NOT MODEL)
+ set(MODEL 64)
+ endif()
+
++include(GNUInstallDirs)
+ message(STATUS "${CMAKE_BUILD_TYPE} version")
+
+ include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+@@ -37,5 +38,5 @@ set (CMAKE_EXE_LINKER_FLAGS -m32)
+ set (CMAKE_SHARED_LINKER_FLAGS -m32)
+ endif()
+
+-install(FILES libda.so libda.so.${API_VERSION} DESTINATION /usr/local/lib)
+-install(FILES dac.h dac_json.h DESTINATION /usr/local/include)
++install(TARGETS da DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES dac.h dac_json.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
diff --git a/dev-libs/device-atlas-api-c/metadata.xml b/dev-libs/device-atlas-api-c/metadata.xml
new file mode 100644
index 000000000000..a1a8f31a03a3
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bertrand@jacquin.bzh</email>
+ <name>Bertrand Jacquin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ DeviceAtlas is the de facto standard for device data across the web, telco, advertising and digital marketing sectors. As the only solution that is indexed for both web and mobile operator environments, DeviceAtlas' patented technology provides a common device identifier to understand device traffic across all connected environments.
+ </longdescription>
+</pkgmetadata>