summaryrefslogtreecommitdiff
path: root/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild')
-rw-r--r--dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild b/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
new file mode 100644
index 000000000000..ad72b64cda06
--- /dev/null
+++ b/dev-libs/d0_blind_id/d0_blind_id-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
+HOMEPAGE="http://git.xonotic.org/?p=xonotic/d0_blind_id.git;a=summary"
+SRC_URI="mirror://github/divVerent/d0_blind_id/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/gmp:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( d0_blind_id.txt )
+
+src_prepare() {
+ # fix out-of-source build
+ sed -i \
+ -e 's, d0_rijndael.c, "$srcdir/d0_rijndael.c",' \
+ configure.ac || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-rijndael
+ --without-openssl
+ --without-tommath
+ )
+ autotools-utils_src_configure
+}