summaryrefslogtreecommitdiff
path: root/dev-libs/cxxopts/cxxopts-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
commit31c69c39a3648b52dd931a40b198714249e8a5ec (patch)
treec7bfb4db01cf185b6b8f7bde72d9cc5d14d8db22 /dev-libs/cxxopts/cxxopts-3.1.0.ebuild
parentdce60e5aa0a12ccc07c10a0a2c3f8f063393b32a (diff)
gentoo auto-resync : 15:02:2024 - 23:36:26
Diffstat (limited to 'dev-libs/cxxopts/cxxopts-3.1.0.ebuild')
-rw-r--r--dev-libs/cxxopts/cxxopts-3.1.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-libs/cxxopts/cxxopts-3.1.0.ebuild b/dev-libs/cxxopts/cxxopts-3.1.0.ebuild
deleted file mode 100644
index 697162ee0804..000000000000
--- a/dev-libs/cxxopts/cxxopts-3.1.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Lightweight C++ command line option parser"
-HOMEPAGE="https://github.com/jarro2783/cxxopts"
-SRC_URI="https://github.com/jarro2783/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="icu test"
-
-RESTRICT="!test? ( test )"
-
-DOCS=(
- README.md
- CHANGELOG.md
-)
-
-src_prepare() {
- sed -r -e 's:-Werror[[:space:]]*::' -i cmake/cxxopts.cmake || die
- cmake_src_prepare
-}
-
-src_configure() {
- local -a mycmakeopts=(
- -DCXXOPTS_BUILD_EXAMPLES:BOOL=OFF
- -DCXXOPTS_BUILD_TESTS:BOOL=$(usex test)
- -DCXXOPTS_ENABLE_INSTALL:BOOL=ON
- -DCXXOPTS_USE_UNICODE_HELP:BOOL=$(usex icu)
- )
- cmake_src_configure
-}