summaryrefslogtreecommitdiff
path: root/dev-libs/crypto++/crypto++-8.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-libs/crypto++/crypto++-8.5.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-libs/crypto++/crypto++-8.5.0.ebuild')
-rw-r--r--dev-libs/crypto++/crypto++-8.5.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-libs/crypto++/crypto++-8.5.0.ebuild b/dev-libs/crypto++/crypto++-8.5.0.ebuild
deleted file mode 100644
index af996cfaed97..000000000000
--- a/dev-libs/crypto++/crypto++-8.5.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/crypto++.asc
-inherit toolchain-funcs verify-sig
-
-DESCRIPTION="C++ class library of cryptographic schemes"
-HOMEPAGE="https://cryptopp.com"
-SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
-SRC_URI+=" verify-sig? ( https://cryptopp.com/cryptopp${PV//.}.zip.sig )"
-S="${WORKDIR}"
-
-LICENSE="Boost-1.0"
-# Bumped to 8.5 in 8.5.0 out of caution
-# subslot is so version (was broken in 8.3.0, check on bumps!)
-SLOT="0/8.5"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ppc ppc64 ~riscv sparc x86 ~x64-macos"
-IUSE="+asm static-libs"
-
-BDEPEND="
- app-arch/unzip
- verify-sig? ( sec-keys/openpgp-keys-crypto++ )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-8.2.0-musl-ldconfig.patch"
-)
-
-config_uncomment() {
- sed -i -e "s://\s*\(#define\s*$1\):\1:" config.h || die
-}
-
-src_prepare() {
- default
-
- use asm || config_uncomment CRYPTOPP_DISABLE_ASM
-
- # ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
- [[ ${CHOST} == *-darwin* ]] && config_uncomment CRYPTOPP_DISABLE_ASM
-}
-
-src_configure() {
- export CXX="$(tc-getCXX)"
- export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- export PREFIX="${EPREFIX}/usr"
- tc-export AR RANLIB
- default
-}
-
-src_compile() {
- emake -f GNUmakefile all shared libcryptopp.pc
-}
-
-src_install() {
- default
-
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
-}