summaryrefslogtreecommitdiff
path: root/dev-libs/crossguid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/crossguid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/crossguid')
-rw-r--r--dev-libs/crossguid/Manifest3
-rw-r--r--dev-libs/crossguid/crossguid-0_pre20150817.ebuild48
-rw-r--r--dev-libs/crossguid/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/crossguid/Manifest b/dev-libs/crossguid/Manifest
new file mode 100644
index 000000000000..0447fbd39fe7
--- /dev/null
+++ b/dev-libs/crossguid/Manifest
@@ -0,0 +1,3 @@
+DIST crossguid-0_pre20150817.tar.gz 46569 BLAKE2B 3384b6c507c4713f5ea0d6012138f3543445a42c7353e934e267b91275f7cf75720a446f5fe24f334b1022946f856a65f5c158d0036c999c761e626c1e30062a SHA512 823ca301f1d3b78a778649cd9169194d98dd33c65cadd5bfb9f86429e82049c99c17e09f093b92675981d2aac2aac25b60cbb157fad57a3e1bada826edd8ba0a
+EBUILD crossguid-0_pre20150817.ebuild 1032 BLAKE2B 4a0aa8d7db11510c8d8c2e57b91dfd9745f1e6ed15d6e98b50dbdab73ff05d4e2a407568620becca250f62e931ec14ba8b9f2eb104eb1c21182ff25aabbc655d SHA512 ecda745d797e6ea79d8aefc5d6edb5f1d956ec3db12a9e8a8ca3ae616e23d611af2c4e2cf9217c6da956c051ef48035f2a3a4a06f5b40d0e872db37ef53085eb
+MISC metadata.xml 249 BLAKE2B e76b8e1b26522b43a97fca8a4678caf478be9cf4c7c6acdc0a51ea6bfaafe545ab12ffcd28dcca146549b0b2cc790fd764e39f0684ec9d369ff7f54f7cad16bb SHA512 81a2303b39a3473f4974960abbafdee923ca794264443e4f54ebba440a3d3ff9cfd247964cb226c6170d1d2a48642e6da25ab9b95f748b7ea1fa7e88afcdcc52
diff --git a/dev-libs/crossguid/crossguid-0_pre20150817.ebuild b/dev-libs/crossguid/crossguid-0_pre20150817.ebuild
new file mode 100644
index 000000000000..f2987df8d078
--- /dev/null
+++ b/dev-libs/crossguid/crossguid-0_pre20150817.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/graeme-hill/crossguid.git"
+ inherit git-r3
+else
+ EGIT_COMMIT="8f399e8bd4252be9952f3dfa8199924cc8487ca4"
+ SRC_URI="https://github.com/graeme-hill/crossguid/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+fi
+
+DESCRIPTION="Lightweight cross platform C++ GUID/UUID library"
+HOMEPAGE="https://github.com/graeme-hill/crossguid"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+# We use libuuid from util-linux.
+DEPEND="sys-apps/util-linux"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" #575544
+
+e() { echo "$@"; "$@"; }
+
+src_compile() {
+ e $(tc-getCXX) \
+ ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} \
+ -std=c++11 \
+ -c guid.cpp -o guid.o \
+ -DGUID_LIBUUID \
+ || die
+
+ e $(tc-getAR) rs libcrossguid.a guid.o || die
+}
+
+src_install() {
+ insinto /usr/include
+ doins guid.h
+ dolib.a libcrossguid.a
+}
diff --git a/dev-libs/crossguid/metadata.xml b/dev-libs/crossguid/metadata.xml
new file mode 100644
index 000000000000..ea03bb762f8a
--- /dev/null
+++ b/dev-libs/crossguid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<upstream>
+ <remote-id type="github">graeme-hill/crossguid</remote-id>
+</upstream>
+</pkgmetadata>