summaryrefslogtreecommitdiff
path: root/dev-libs/console_bridge/console_bridge-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-libs/console_bridge/console_bridge-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-libs/console_bridge/console_bridge-9999.ebuild')
-rw-r--r--dev-libs/console_bridge/console_bridge-9999.ebuild51
1 files changed, 44 insertions, 7 deletions
diff --git a/dev-libs/console_bridge/console_bridge-9999.ebuild b/dev-libs/console_bridge/console_bridge-9999.ebuild
index 1fac726c6456..a93aeb6410c5 100644
--- a/dev-libs/console_bridge/console_bridge-9999.ebuild
+++ b/dev-libs/console_bridge/console_bridge-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,21 +9,58 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/console_bridge"
fi
-inherit ${SCM} cmake-utils multilib
+inherit ${SCM} cmake
+AMENT_LINT_VER=0.9.5
+EXTERNAL_PROGS="
+ https://raw.githubusercontent.com/ament/ament_lint/${AMENT_LINT_VER}/ament_cppcheck/ament_cppcheck/main.py -> ${P}-ament-${AMENT_LINT_VER}-cppcheck.py
+ https://raw.githubusercontent.com/ament/ament_lint/${AMENT_LINT_VER}/ament_cpplint/ament_cpplint/cpplint.py -> ${P}-ament-${AMENT_LINT_VER}-cpplint.py
+"
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
- SRC_URI=""
+ SRC_URI="${EXTERNAL_PROGS}"
else
KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="${EXTERNAL_PROGS}
+ https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout"
-HOMEPAGE="http://wiki.ros.org/console_bridge"
+HOMEPAGE="https://wiki.ros.org/console_bridge"
LICENSE="BSD"
-SLOT="0/4"
-IUSE=""
+SLOT="0/1"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/boost:=[threads]"
DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-util/cppcheck
+ )
+"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_prepare() {
+ # Avoid wgeting it. #733704
+ sed -e 's/add_dependencies(console_bridge wget_cppchec/#/' -i test/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+
+ # For tests
+ if use test ; then
+ cp "${DISTDIR}/${P}-ament-${AMENT_LINT_VER}-cppcheck.py" "${BUILD_DIR}/test/cppcheck.py" || die
+ cp "${DISTDIR}/${P}-ament-${AMENT_LINT_VER}-cpplint.py" "${BUILD_DIR}/test/cpplint.py" || die
+ fi
+}
+
+src_test() {
+ export AMENT_CPPCHECK_ALLOW_1_88=yes
+ cmake_src_test
+}