summaryrefslogtreecommitdiff
path: root/dev-libs/cloog/cloog-0.18.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/cloog/cloog-0.18.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/cloog/cloog-0.18.1.ebuild')
-rw-r--r--dev-libs/cloog/cloog-0.18.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/cloog/cloog-0.18.1.ebuild b/dev-libs/cloog/cloog-0.18.1.ebuild
new file mode 100644
index 000000000000..91a16c323189
--- /dev/null
+++ b/dev-libs/cloog/cloog-0.18.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="A loop generator for scanning polyhedra"
+HOMEPAGE="http://www.bastoul.net/cloog/"
+SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]
+ >=dev-libs/isl-0.12.2:0/10[${MULTILIB_USEDEP}]
+ !dev-libs/cloog-ppl"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_prepare() {
+ # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
+ # sed to avoid eautoreconf
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-gmp=system \
+ --with-isl=system \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}