summaryrefslogtreecommitdiff
path: root/dev-libs/cl/cl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/cl/cl-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/cl/cl-9999.ebuild')
-rw-r--r--dev-libs/cl/cl-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/cl/cl-9999.ebuild b/dev-libs/cl/cl-9999.ebuild
new file mode 100644
index 000000000000..da4f1445d486
--- /dev/null
+++ b/dev-libs/cl/cl-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils git-r3 multilib
+
+DESCRIPTION="OpenCL bindings for Erlang"
+HOMEPAGE="https://github.com/tonyrog/cl"
+EGIT_REPO_URI="https://github.com/tonyrog/cl.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-lang/erlang-16
+ virtual/opencl
+ dev-util/rebar
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ rebar compile || die
+}
+
+src_install() {
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ CL_DIR="${ERLANG_DIR}/${P}"
+ insinto "${CL_DIR}"
+ doins -r ebin src include c_src examples
+}