summaryrefslogtreecommitdiff
path: root/dev-libs/cglm/cglm-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
commit280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (patch)
tree604fa555cdb815d5774494412f041887debf5220 /dev-libs/cglm/cglm-0.9.1.ebuild
parent2ef316f0ffbd90d833effd2d09d1232e5767e321 (diff)
gentoo auto-resync : 17:08:2023 - 03:31:10
Diffstat (limited to 'dev-libs/cglm/cglm-0.9.1.ebuild')
-rw-r--r--dev-libs/cglm/cglm-0.9.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/cglm/cglm-0.9.1.ebuild b/dev-libs/cglm/cglm-0.9.1.ebuild
new file mode 100644
index 000000000000..8adee7688d32
--- /dev/null
+++ b/dev-libs/cglm/cglm-0.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="sphinx"
+DOCS_AUTODOC=1
+DOCS_DEPEND="dev-python/sphinx-rtd-theme"
+DOCS_DIR="${S}/docs/source"
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 docs meson
+
+DESCRIPTION="OpenGL Mathematics (glm) for C"
+HOMEPAGE="https://github.com/recp/cglm"
+SRC_URI="https://github.com/recp/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ # DOCS_DEPEND needs DOCS_AUTODOC which needs the extension
+ sed -i -e "/^extensions/s/$/ 'sphinx.ext.autodoc',/" docs/source/conf.py || die
+}
+src_configure() {
+ local emesonargs=(
+ $(meson_use test build_tests)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+ docs_compile
+}