summaryrefslogtreecommitdiff
path: root/dev-libs/cgicc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
commit2929788def9a92c1eb237eed93fbdb0c02838bbf (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /dev-libs/cgicc
parentab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (diff)
Revert "gentoo resync : 13.10.2019"
This reverts commit ab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030.
Diffstat (limited to 'dev-libs/cgicc')
-rw-r--r--dev-libs/cgicc/Manifest5
-rw-r--r--dev-libs/cgicc/cgicc-3.2.16.ebuild48
-rw-r--r--dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch13
-rw-r--r--dev-libs/cgicc/files/cgicc-3.2.16-fix-doc-building.patch34
-rw-r--r--dev-libs/cgicc/metadata.xml17
5 files changed, 117 insertions, 0 deletions
diff --git a/dev-libs/cgicc/Manifest b/dev-libs/cgicc/Manifest
new file mode 100644
index 000000000000..2b2c8ba73561
--- /dev/null
+++ b/dev-libs/cgicc/Manifest
@@ -0,0 +1,5 @@
+AUX 3.2.10-fix-pkgconfig.patch 419 BLAKE2B 345f161cc6365dfc34e9740e83d44378fee197849dc2a79e96a40e205ab979970ce530a4e701efd5c3fd9e02e0de96987648b6244bc7b2b09514554b8c747789 SHA512 f2b688795317f11f67070b94227ef75afed02353cba5d0d98918a6107fc3a1ec107ab1b33ec29b32047098ca0d2acfda087016eef7de16be58af72ea7dd53977
+AUX cgicc-3.2.16-fix-doc-building.patch 812 BLAKE2B fe7a218331dca0618ce473d60968241ef19d5cce0008bb20018f0effdaa63a5f5c607b0f78df3eefbfb49cd2ed37e2f77d8a65bb781fccaa6014311986618f2d SHA512 c31d72d32dc0df5ec5b5d2286865e969d4ec432b3551c533d2b23c1acae8c4a821ea7891980f2af22da16c71f0561a19a38070a4394f43b4cfc4ec9ec5ed51e1
+DIST cgicc-3.2.16.tar.gz 1409037 BLAKE2B 414f0f9e1cfe8cac0bc55ed34bdd6d745595e2fd55329923fa47d269bb7abb3f1d2761ff9810c96930657c563f5f8aa5285c58943fca072273af3088205629ed SHA512 3334777204f3de57e80f759503db08076fe8e7a12cf779bb50345e7d06c6be4cc612b473bd74eded5debd79684b49c5bb79bcfff1b631a815c7fe9d14960d537
+EBUILD cgicc-3.2.16.ebuild 937 BLAKE2B 1770a5d37e03b1fa9ea56ba19393ab75fa3855ec6dec254df8a3efc079ec122db7da54757684d18dec53f022a5299d7bbdc6fb8075a14becd3ce80423817acfb SHA512 71f02a35b62b36e57064776817b4407f5ab32d404f8760e92a93c4131fce786536cdbd0807636df5c8fff23f11589b9b36d7fd1b21596b176291c37bc6d0047c
+MISC metadata.xml 796 BLAKE2B 8b502996ad54d8dabf3c8279440115f39fb64bb70c1e72bd5ddb90b224f0103c0e011dc0f5985b5fd279a3bd24a05e98d6ea2f408d13cf7881b90bf71efb230f SHA512 5cf675335892f7f230841d62bb77fb947207869083f340c735d3a5b78d39b43b9f0cb911e206f854c2291481420e72fea1abcde2853566b2e6fea858b2695fbc
diff --git a/dev-libs/cgicc/cgicc-3.2.16.ebuild b/dev-libs/cgicc/cgicc-3.2.16.ebuild
new file mode 100644
index 000000000000..55dbede7198b
--- /dev/null
+++ b/dev-libs/cgicc/cgicc-3.2.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A C++ class library for writing CGI applications"
+HOMEPAGE="https://www.gnu.org/software/cgicc/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3 doc? ( FDL-1.2 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}/3.2.10-fix-pkgconfig.patch"
+ "${FILESDIR}/${PN}-3.2.16-fix-doc-building.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable examples demos) \
+ $(use_enable doc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc {contrib,demo}/{*.{cpp,h},*.cgi,README}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch b/dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch
new file mode 100644
index 000000000000..af1c069334e9
--- /dev/null
+++ b/dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch
@@ -0,0 +1,13 @@
+diff --git a/cgicc.pc.in b/cgicc.pc.in
+index 2006be8..e42c9bf 100644
+--- a/cgicc.pc.in
++++ b/cgicc.pc.in
+@@ -7,5 +7,5 @@ Name: cgicc
+ Description: GNU cgicc is an ANSI C++ compliant class library that greatly simplifies the creation of CGI applications for the World Wide Web.
+ Requires:
+ Version: @VERSION@
+-Libs: -L${libdir}
+-Cflags:
+\ No newline at end of file
++Libs: -L${libdir} -lcgicc
++Cflags: -I${includedir}
diff --git a/dev-libs/cgicc/files/cgicc-3.2.16-fix-doc-building.patch b/dev-libs/cgicc/files/cgicc-3.2.16-fix-doc-building.patch
new file mode 100644
index 000000000000..4430ffafaf95
--- /dev/null
+++ b/dev-libs/cgicc/files/cgicc-3.2.16-fix-doc-building.patch
@@ -0,0 +1,34 @@
+Fix build system properly, such that hacking the Makefile.in's
+is not required anymore.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -77,6 +77,13 @@
+ AC_MSG_RESULT($cgicc_demos)
+ AM_CONDITIONAL(DEMOS, test "$cgicc_demos" = yes)
+
++dnl enable/disable the docs, if specified
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--disable-doc], [Disable building documentation]))
++AC_MSG_CHECKING([whether to build the cgicc docs])
++AC_MSG_RESULT([$enable_doc])
++AM_CONDITIONAL([DOCS], [test "x$enable_doc" != "xno"])
++
+ if test "$cgicc_demos" = yes; then
+ AC_CONFIG_FILES(demo/Makefile)
+ AC_CHECK_FUNCS([gethostbyaddr])
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,7 +10,11 @@
+
+ ACLOCAL_AMFLAGS=
+
+-SUBDIRS = cgicc doc support $(DEMO)
++SUBDIRS = cgicc support $(DEMO)
++
++if DOCS
++SUBDIRS += doc
++endif
+
+ CLEANFILES = *~
+
diff --git a/dev-libs/cgicc/metadata.xml b/dev-libs/cgicc/metadata.xml
new file mode 100644
index 000000000000..c65be4a96414
--- /dev/null
+++ b/dev-libs/cgicc/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ GNU cgicc is an ANSI C++ compliant class library that greatly
+ simplifies the creation of CGI applications for the World Wide
+ Web. cgicc performs the following functions:
+
+ - Parses both GET and POST form data transparently
+ - Provides string, integer, floating-point and single- and multiple-choice retrieval methods for form data
+ - Provides methods for saving and restoring CGI environments to aid in application debugging
+ - Provides full on-the-fly HTML 4.0 generation capabilities, with support for cookies
+ - Supports HTTP file upload
+ - Compatible with FastCGI
+ </longdescription>
+</pkgmetadata>