summaryrefslogtreecommitdiff
path: root/dev-libs/capnproto/capnproto-0.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-libs/capnproto/capnproto-0.10.2.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-libs/capnproto/capnproto-0.10.2.ebuild')
-rw-r--r--dev-libs/capnproto/capnproto-0.10.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/capnproto/capnproto-0.10.2.ebuild b/dev-libs/capnproto/capnproto-0.10.2.ebuild
new file mode 100644
index 000000000000..0a6728f73a19
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.10.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/091"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ if use arm || use ppc || use mips || [[ ${CHOST} == *i486* ]] ; then
+ # append-libs won't work here, cmake doesn't respect it
+ # ... and ldflags gets missed once
+ append-flags -latomic
+ fi
+
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}