summaryrefslogtreecommitdiff
path: root/dev-libs/c-blosc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
commita833e3f4a431b8eea751b7420e127787f9c92117 (patch)
treeb941d23e9e3d5f070b01feb15ef927839af7456a /dev-libs/c-blosc/files
parent4cd2370bed609c118b6edfde5d3f116e5c35b897 (diff)
gentoo resync : 04.12.2017
Diffstat (limited to 'dev-libs/c-blosc/files')
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch30
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch22
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch27
3 files changed, 0 insertions, 79 deletions
diff --git a/dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch b/dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch
deleted file mode 100644
index 02c5fc2d8ab3..000000000000
--- a/dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Make the build system respect CFLAGS
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -195,7 +195,7 @@
- CMAKE_SYSTEM_PROCESSOR STREQUAL AMD64)
- if(CMAKE_C_COMPILER_ID STREQUAL GNU)
- # We need C99 (GNU99 more exactly)
-- SET(CMAKE_C_FLAGS "-std=gnu99")
-+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- set(COMPILER_SUPPORT_SSE2 TRUE)
- if(CMAKE_C_COMPILER_VERSION VERSION_GREATER 4.7 OR CMAKE_C_COMPILER_VERSION VERSION_EQUAL 4.7)
- set(COMPILER_SUPPORT_AVX2 TRUE)
-@@ -244,16 +244,6 @@
- endif()
-
- # flags
--# @TODO: set -Wall
--# @NOTE: -O3 is enabled in Release mode (CMAKE_BUILD_TYPE="Release")
--
--# Set the "-msse2" build flag only if the CMAKE_C_FLAGS is not already set.
--# Probably "-msse2" should be appended to CMAKE_C_FLAGS_RELEASE.
--if(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
-- if(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
-- set(CMAKE_C_FLAGS -msse2 CACHE STRING "C flags." FORCE)
-- endif(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
--endif(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
-
- if(MSVC)
- if(NOT CMAKE_C_FLAGS)
diff --git a/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch b/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch
deleted file mode 100644
index 484db1f6dd3c..000000000000
--- a/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- hdf5/CMakeLists.txt.orig 2014-02-05 16:55:55.001344161 -0800
-+++ hdf5/CMakeLists.txt 2014-02-05 16:57:03.767739650 -0800
-@@ -23,16 +23,16 @@
-
- # install
- install(FILES blosc_filter.h DESTINATION include COMPONENT HDF5_FILTER_DEV)
--install(TARGETS blosc_filter_static DESTINATION lib COMPONENT HDF5_FILTER)
-+install(TARGETS blosc_filter_shared DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER)
- if(BUILD_STATIC)
- install(
-- TARGETS blosc_filter_shared DESTINATION lib COMPONENT HDF5_FILTER_DEV)
-+ TARGETS blosc_filter_static DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER_DEV)
- endif(BUILD_STATIC)
-
-
- # test
- if(BUILD_TESTS)
- add_executable(example example.c)
-- target_link_libraries(example blosc_filter_static ${HDF5_LIBRARIES})
-+ target_link_libraries(example blosc_filter_shared ${HDF5_LIBRARIES})
- add_test(test_hdf5_filter example)
- endif(BUILD_TESTS)
diff --git a/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch b/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch
deleted file mode 100644
index c46f66987445..000000000000
--- a/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch
+++ /dev/null
@@ -1,27 +0,0 @@
- hdf5/CMakeLists.txt | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/hdf5/CMakeLists.txt b/hdf5/CMakeLists.txt
-index d91194f..032a292 100644
---- a/hdf5/CMakeLists.txt
-+++ b/hdf5/CMakeLists.txt
-@@ -44,16 +44,16 @@ endif(MSVC)
-
- # install
- install(FILES blosc_filter.h DESTINATION include COMPONENT HDF5_FILTER_DEV)
--install(TARGETS blosc_filter_shared DESTINATION lib COMPONENT HDF5_FILTER)
-+install(TARGETS blosc_filter_shared DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER)
- if(BUILD_STATIC)
- install(
-- TARGETS blosc_filter_static DESTINATION lib COMPONENT HDF5_FILTER_DEV)
-+ TARGETS blosc_filter_static DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER_DEV)
- endif(BUILD_STATIC)
-
-
- # test
- if(BUILD_TESTS)
- add_executable(example example.c)
-- target_link_libraries(example blosc_filter_static ${HDF5_LIBRARIES})
-+ target_link_libraries(example blosc_filter_shared ${HDF5_LIBRARIES})
- add_test(test_hdf5_filter example)
- endif(BUILD_TESTS)