summaryrefslogtreecommitdiff
path: root/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch')
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
new file mode 100644
index 000000000000..d385d5263710
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
@@ -0,0 +1,21 @@
+Make the build system respect CFLAGS
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,16 +244,6 @@
+ endif()
+
+ # flags
+-# @TODO: set -Wall
+-# @NOTE: -O3 is enabled in Release mode (CMAKE_BUILD_TYPE="Release")
+-
+-# Set the "-msse2" build flag only if the CMAKE_C_FLAGS is not already set.
+-# Probably "-msse2" should be appended to CMAKE_C_FLAGS_RELEASE.
+-if(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+- if(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+- set(CMAKE_C_FLAGS -msse2 CACHE STRING "C flags." FORCE)
+- endif(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+-endif(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+
+ if(MSVC)
+ if(NOT CMAKE_C_FLAGS)