summaryrefslogtreecommitdiff
path: root/dev-libs/botan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-libs/botan
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest3
-rw-r--r--dev-libs/botan/botan-2.19.1.ebuild165
2 files changed, 168 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 28757dd32130..de4c048c9006 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,4 +1,7 @@
DIST Botan-2.18.2.tar.xz 5996928 BLAKE2B 5c5ac1e8e2de16a012aa5716138f4c2d2b8178f0a811993e5e297aa5ae9e7f6d5a4f182d50566f5848a4f93a88bcec622291a15370c4c017361ca65d3bb189bf SHA512 ccf9286ee891fb201065a0a6a991ce78ef7f5dd0caf04010527cd524b824ea470e5ce302853c1839e999a1b3dafb2e82eb298036a37d11f0cf3df5fa09529d9c
DIST Botan-2.18.2.tar.xz.asc 488 BLAKE2B 03744e95f52031295162b63dc34d7e0fd9a6b01ae751a809eed5f24c46017fca253c8d42c88b568566f393f0e6dd55d488ef56223d164941386690e2accdf296 SHA512 6764bcdb52a3a28672bcf22f8c364c926511a7b7c9bc227ba15f1e4b2feb9b371a9a4bd9bb1ee43e85faacbef4df5ce39a158357b4ce3706a00f4220bea8d926
+DIST Botan-2.19.1.tar.xz 6088380 BLAKE2B 7a2d50bb66ea4a1875857bea769bcc30f397170a10a70377c3963d92e33321a079271c1e235a7892e33ec5b1bc19e4df8336b2586548ccd849f52ebfa47d9c8f SHA512 e604be0e7e82da89e3e1949d3035a87dc63314bd9854d5fe5129ccb3ed5bc78edb0406c7f8ad1a152b59a63b6d98ba207a0851a08428c3452cce794614b5eef5
+DIST Botan-2.19.1.tar.xz.asc 488 BLAKE2B 36f27e294fed60ea4d9ee9d919a58fc431a1bf9bdec8c12d30f2cba537a70b0e22f6a7c882cf7a80dc10aeee256f9f4a32129b55d2ab5df192d16759638feaa4 SHA512 2cd57bf97630d8f79cc0a87da79d3b338bd3b33b02ded16f6b60d5fd6cb3ea62105f577deb3b8d061f56a09ff902ff553ea3a0c603d5c3bd53a905024a2f457b
EBUILD botan-2.18.2-r1.ebuild 4074 BLAKE2B ad2d28abbf64514ed31b13920fa302274b7e142e635f3ad4c5200695bc63f945908016c2f532fbfd008cd71f3824e0c40deed9f235fed9760733ccde90f2601f SHA512 c92b0f2f1f249174368918e6614dae17108be3a8da0dccacbe27bb2eaf45d097187e2afb1ed581f471c4dc7f19198fa27b3f41cb4ec6e7d6062b90840fa4216c
+EBUILD botan-2.19.1.ebuild 4149 BLAKE2B f5be0ee5ca561e8a496a5e1f6328eb06fa9f92b5bbce0067eec6e7a77f7696f652f3afd496bb680d4b06b9f05cad53e0d7ff88f8d4206e352507dd595761b20a SHA512 253ba93a34330775985d8e7199bb3ba88e1b8f95069ff50e52bb8689ff1aa27064d10acb80c2793a51d4c34efa72600961286369de703c7237be7d3a33438a79
MISC metadata.xml 519 BLAKE2B 78e28054a5c35b101d1f1b20ce1095a8a4f0ee8cf312e8d4f3aa711310d34d48878040ffa2a5a7a6600b071cfb5898b69508796aacd3f1d7658c2f30cbda1200 SHA512 9b039acb51f28ad8f21ed310e34d0d36fa7c5dd763fe8661a7ae21dc8dcc08c55d1eb9f1d0e519773697fe18600ffb3424811244e6f7ae243f6e675988006142
diff --git a/dev-libs/botan/botan-2.19.1.ebuild b/dev-libs/botan/botan-2.19.1.ebuild
new file mode 100644
index 000000000000..6138e73f21d7
--- /dev/null
+++ b/dev-libs/botan/botan-2.19.1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/botan.asc
+inherit python-r1 toolchain-funcs verify-sig
+
+MY_P="Botan-${PV}"
+DESCRIPTION="C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
+SRC_URI+=" verify-sig? ( https://botan.randombit.net/releases/${MY_P}.tar.xz.asc )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="2/$(ver_cut 1-2)" # soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos"
+IUSE="doc boost bzip2 lzma python ssl static-libs sqlite zlib"
+
+CPU_USE=(
+ cpu_flags_arm_{aes,neon}
+ cpu_flags_ppc_altivec
+ cpu_flags_x86_{aes,avx2,popcnt,rdrand,sse2,ssse3,sse4_1,sse4_2}
+)
+
+IUSE+=" ${CPU_USE[@]}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# NOTE: Boost is needed at runtime too for the CLI tool.
+DEPEND="
+ boost? ( >=dev-libs/boost-1.48:= )
+ bzip2? ( >=app-arch/bzip2-1.0.5:= )
+ lzma? ( app-arch/xz-utils:= )
+ python? ( ${PYTHON_DEPS} )
+ ssl? ( dev-libs/openssl:= )
+ sqlite? ( dev-db/sqlite:3= )
+ zlib? ( >=sys-libs/zlib-1.2.3:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ ')
+ verify-sig? ( sec-keys/openpgp-keys-botan )
+"
+
+# NOTE: Considering patching Botan?
+# Please see upstream's guidance:
+# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches
+
+python_check_deps() {
+ if use doc ; then
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ python_setup
+
+ local disable_modules=(
+ $(usev !boost 'boost')
+ )
+
+ if [[ -z "${DISABLE_MODULES}" ]] ; then
+ elog "Disabling module(s): ${disable_modules[@]}"
+ fi
+
+ local chostarch="${CHOST%%-*}"
+
+ # Arch specific wrangling
+ local myos=
+ case ${CHOST} in
+ *-darwin*)
+ myos=darwin
+ ;;
+
+ *)
+ myos=linux
+
+ if [[ ${CHOST} == *hppa* ]] ; then
+ chostarch=parisc
+ elif [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+ chostarch="sparc32-v9"
+ fi
+ ;;
+
+ esac
+
+ local pythonvers=()
+ if use python ; then
+ _append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+
+ python_foreach_impl _append
+ fi
+
+ local myargs=(
+ # Intrinsics
+ # TODO: x86 RDSEED (new CPU_FLAGS_X86?)
+ # TODO: POWER Crypto (new CPU_FLAGS_PPC?)
+ $(usev !cpu_flags_arm_aes '--disable-armv8crypto')
+ $(usev !cpu_flags_arm_neon '--disable-neon')
+ $(usev !cpu_flags_ppc_altivec '--disable-altivec')
+ $(usev !cpu_flags_x86_aes '--disable-aes-ni')
+ $(usev !cpu_flags_x86_avx2 '--disable-avx2')
+ $(usev !cpu_flags_x86_popcnt '--disable-bmi2')
+ $(usev !cpu_flags_x86_rdrand '--disable-rdrand')
+ $(usev !cpu_flags_x86_sse2 '--disable-sse2')
+ $(usev !cpu_flags_x86_ssse3 '--disable-ssse3')
+ $(usev !cpu_flags_x86_sse4_1 '--disable-sse4.1')
+ $(usev !cpu_flags_x86_sse4_2 '--disable-sse4.2')
+
+ # HPPA's GCC doesn't support SSP (presumably due to stack direction)
+ $(usev hppa '--without-stack-protector')
+
+ $(use_with boost)
+ $(use_with bzip2)
+ $(use_with doc documentation)
+ $(use_with doc sphinx)
+ $(use_with lzma)
+ $(use_enable static-libs static-library)
+ $(use_with ssl openssl)
+ $(use_with sqlite sqlite3)
+ $(use_with zlib)
+
+ --cpu=${chostarch}
+ --docdir=share/doc
+ --disable-modules=$( IFS=","; echo "${disable_modules[*]}" )
+ --distribution-info="Gentoo ${PVR}"
+ --libdir=$(get_libdir)
+
+ # Don't install Python bindings automatically
+ # (do it manually later in the right place)
+ # https://bugs.gentoo.org/723096
+ --no-install-python-module
+
+ --os=${myos}
+ --prefix="${EPREFIX}/usr"
+ --with-endian="$(tc-endian)"
+ --with-python-version=$( IFS=","; echo "${pythonvers[*]}" )
+ --without-doxygen
+ )
+
+ tc-export CC CXX AR
+
+ ${EPYTHON} configure.py "${myargs[@]}" || die "configure.py failed with ${EPYTHON}"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+
+ # Manually install the Python bindings (bug #723096)
+ if use python ; then
+ python_foreach_impl python_domodule src/python/botan2.py
+ fi
+}