summaryrefslogtreecommitdiff
path: root/dev-libs/boost-numpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/boost-numpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/boost-numpy')
-rw-r--r--dev-libs/boost-numpy/Manifest2
-rw-r--r--dev-libs/boost-numpy/boost-numpy-9999.ebuild48
-rw-r--r--dev-libs/boost-numpy/metadata.xml12
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/boost-numpy/Manifest b/dev-libs/boost-numpy/Manifest
new file mode 100644
index 000000000000..33d289b95bcf
--- /dev/null
+++ b/dev-libs/boost-numpy/Manifest
@@ -0,0 +1,2 @@
+EBUILD boost-numpy-9999.ebuild 1015 BLAKE2B f4a64e0316f8300c21068ca4cff033e9f7b7601fd6b076a76620994ee7d7d859e23f423c87180faea5aaf8d2c12c5c69d945c60b1e12b1a43a16406a38a15cc5 SHA512 63aef7073e39e94a8bd14196c8f45507672b9bc7794d0b446e899bab0487760d9379666be50e994caaf20718ccbb333f7259efb26db46e160c744dd34d1a770b
+MISC metadata.xml 537 BLAKE2B 9f60a0689c92fcc61b005c56d5412b33423c03fad54e589a3ce268ba875538555f152f54e6b7107bf4c0294cd00811ac081acff6d4cddcfdcfd747f20ea9cce0 SHA512 44ff7d8681515dc0c0179e3922115c8260f19c39832ac0f190037a2d1dd117998e89163e33ecb4ca3214d2effd852e3bea5e0902cd269e3834aab82e91f622e7
diff --git a/dev-libs/boost-numpy/boost-numpy-9999.ebuild b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
new file mode 100644
index 000000000000..c084c9a645f9
--- /dev/null
+++ b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Boost.Python interface for NumPy"
+HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ndarray/Boost.NumPy.git"
+else
+ SRC_URI="https://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT=0
+KEYWORDS=""
+
+IUSE="doc examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/boost[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Make sure that new Python ABI names are searched too
+ sed -i \
+ -e 's/PythonLibsNew/PythonLibs/' \
+ -e 's/python3/python/' \
+ CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r libs/numpy/doc/*
+ use examples && dodoc -r libs/numpy/example
+}
diff --git a/dev-libs/boost-numpy/metadata.xml b/dev-libs/boost-numpy/metadata.xml
new file mode 100644
index 000000000000..fd7a29272578
--- /dev/null
+++ b/dev-libs/boost-numpy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+ <longdescription>It is intended as a replacement for the old numeric support in Boost.Python proper, which is now out-of-date and does not support C/C++ pointer access to the data.</longdescription>
+ <upstream>
+ <remote-id type="github">ndarray/Boost.NumPy</remote-id>
+ </upstream>
+</pkgmetadata>