summaryrefslogtreecommitdiff
path: root/dev-libs/boost-numpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/boost-numpy
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/boost-numpy')
-rw-r--r--dev-libs/boost-numpy/Manifest4
-rw-r--r--dev-libs/boost-numpy/boost-numpy-9999.ebuild48
-rw-r--r--dev-libs/boost-numpy/metadata.xml13
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/boost-numpy/Manifest b/dev-libs/boost-numpy/Manifest
new file mode 100644
index 000000000000..05c386ef69a1
--- /dev/null
+++ b/dev-libs/boost-numpy/Manifest
@@ -0,0 +1,4 @@
+EBUILD boost-numpy-9999.ebuild 1011 SHA256 b87ffa74047bedc2b32437ddea212964baff865581aed70869b8d67ff9d3ef14 SHA512 2a13be5f2586f2df6458cf4edee0b972d84c548cd0fedbbfcfe95d00327da0b54b3272b7be843dce898185469888e859cb42db121128027360a0e65d175121de WHIRLPOOL 2f6bb6ecdf36d3e5d39855c702eaae71c91e2d7e11dfc6622015ac0914cc5934fd1f6dbb5ccef0ac9281d50737128eee482ad9302442a7db28b8cfcabe058713
+MISC ChangeLog 2840 SHA256 a7b4ad699145b85739799ca9afe20109f22e650e988fd9da960b749a3c3bca42 SHA512 c1fbf36db375f03fb0ba7845ad816f94ef9502b19cde04f9ebdb05690eaecd4abd87cd3a1b4e3d8b4c49bcc47a76eff9f9e67ab0e50e735b1093e2a4db103775 WHIRLPOOL caca9497560f167ae0064c6baefa09d508297c834c6b6d0bb308df584dcf3ed22ce96e62bb7948fdd06f8dd6605652c45a257005dcf3075c0aebba7d27bb43f3
+MISC ChangeLog-2015 879 SHA256 392e71b8c83e73fa0d3325cd4df0b1753ec347fe60281e4bf856adeba51bf40e SHA512 1743ec718abadb1bf6ba7ed76939a227521d74e89185b4ddd3bba8f7bc95711fbab5d0a699c9cd628c8cd1d89d6523da96b1aaa0bbc9d09904c07fccc8e69c1c WHIRLPOOL d18a1056bfed897cd342b619d4d5e5733e8e9151894a5b32c50e2e4ec7c8fc2b1e1727235c561071d989ec70e2d99bcae5b39facdc96496b23520e91ca6e6415
+MISC metadata.xml 622 SHA256 b31bf6a5efc4220db9a3299f6387fa68c89cb7cb24b857663f76bc58408d78bf SHA512 861356b9dc2576b7979b9c0489ef6b91e42047cd5c74fd7323e79be752511d1a79b396687fed0d51353e0a52cb68181609addd5af940158acf7ffbdbc3cec901 WHIRLPOOL 50c3bab33e1f8bcb656216234b95e89c3dd48dd86078283c05277abd9c322b0cf7238733e8a0f91fdf766edb19d76edb0ca730fa4043817d8ad579e9bfaad143
diff --git a/dev-libs/boost-numpy/boost-numpy-9999.ebuild b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
new file mode 100644
index 000000000000..e6dd4141386a
--- /dev/null
+++ b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Boost.Python interface for NumPy"
+HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ndarray/Boost.NumPy.git"
+else
+ SRC_URI="https://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT=0
+KEYWORDS=""
+
+IUSE="doc examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/boost[python,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Make sure that new Python ABI names are searched too
+ sed -i \
+ -e 's/PythonLibsNew/PythonLibs/' \
+ -e 's/python3/python/' \
+ CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r libs/numpy/doc/*
+ use examples && dodoc -r libs/numpy/example
+}
diff --git a/dev-libs/boost-numpy/metadata.xml b/dev-libs/boost-numpy/metadata.xml
new file mode 100644
index 000000000000..6b714f91d43b
--- /dev/null
+++ b/dev-libs/boost-numpy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ <description>an extension for Boost.Python that adds NumPy support</description>
+ </maintainer>
+ <longdescription>It is intended as a replacement for the old numeric support in Boost.Python proper, which is now out-of-date and does not support C/C++ pointer access to the data.</longdescription>
+ <upstream>
+ <remote-id type="github">ndarray/Boost.NumPy</remote-id>
+ </upstream>
+</pkgmetadata>