summaryrefslogtreecommitdiff
path: root/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
new file mode 100644
index 000000000000..d0853b7a5336
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-7.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+MY_P="gc-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="http://www.hboehm.info/gc/"
+SRC_URI="http://www.hboehm.info/gc/gc_source/${MY_P}.tar.gz"
+
+LICENSE="boehm-gc"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86"
+IUSE="cxx threads"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^SUBDIRS/s/doc//' Makefile.in || die
+ epatch "${FILESDIR}"/${PN}-6.5-gentoo.patch
+ epatch "${FILESDIR}"/gc6.6-builtin-backtrace-uclibc.patch
+ sed '/Cflags/s:$:/gc:g' -i bdw-gc.pc.in || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable cxx cplusplus) \
+ $(use threads || echo --disable-threads)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}"/usr/share/gc || die
+
+ # dist_noinst_HEADERS
+ insinto /usr/include/gc
+ doins include/{cord.h,ec.h,javaxfc.h}
+ insinto /usr/include/gc/private
+ doins include/private/*.h
+
+ dodoc README.QUICK doc/README* doc/barrett_diagram
+ dohtml doc/*.html
+ newman doc/gc.man GC_malloc.1
+}