summaryrefslogtreecommitdiff
path: root/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild')
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
index 69a3ccb8f34f..a04082f9c8ae 100644
--- a/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
+++ b/dev-libs/beecrypt/beecrypt-4.2.1-r4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools java-pkg-opt-2 python-single-r1
+inherit autotools flag-o-matic java-pkg-opt-2 python-single-r1
DESCRIPTION="General-purpose cryptography library"
HOMEPAGE="https://sourceforge.net/projects/beecrypt/"
@@ -43,7 +43,7 @@ PATCHES=(
pkg_setup() {
use python && python-single-r1_pkg_setup
- use java && java-pkg-opt-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
}
src_prepare() {
@@ -52,7 +52,12 @@ src_prepare() {
}
src_configure() {
+ # ICU needs char16_t support now
+ # bug 649548
+ append-cxxflags -std=c++14
+
# cplusplus needs threads support
+ ac_cv_java_include=$(use java && java-pkg_get-jni-cflags) \
econf \
--disable-expert-mode \
$(use_enable static-libs static) \