summaryrefslogtreecommitdiff
path: root/dev-libs/bcm2835/bcm2835-1.52.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/bcm2835/bcm2835-1.52.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/bcm2835/bcm2835-1.52.ebuild')
-rw-r--r--dev-libs/bcm2835/bcm2835-1.52.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/bcm2835/bcm2835-1.52.ebuild b/dev-libs/bcm2835/bcm2835-1.52.ebuild
new file mode 100644
index 000000000000..df21044d8808
--- /dev/null
+++ b/dev-libs/bcm2835/bcm2835-1.52.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Provides access to GPIO and other IO functions on the Broadcom BCM2835"
+HOMEPAGE="http://www.airspayce.com/mikem/bcm2835/"
+SRC_URI="http://www.airspayce.com/mikem/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ default
+}