summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-io
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/aws-c-io
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/aws-c-io')
-rw-r--r--dev-libs/aws-c-io/Manifest4
-rw-r--r--dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild42
-rw-r--r--dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch12
-rw-r--r--dev-libs/aws-c-io/metadata.xml23
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/aws-c-io/Manifest b/dev-libs/aws-c-io/Manifest
new file mode 100644
index 000000000000..2129811fb9b2
--- /dev/null
+++ b/dev-libs/aws-c-io/Manifest
@@ -0,0 +1,4 @@
+AUX aws-c-io-0.7.0-cmake-prefix.patch 536 BLAKE2B 7e4220bfea17be839ea3e9c1ea16ed2e375d8fb2d4e5eb1dbd551fd395332e0ba8865b02fdb10c542b5b54ce2e3a4c488bb2792fa1ec52f53d541db84ca985e1 SHA512 786c8fa9eb8233d39aec9f4335b55eb80ad0ccd6ea52e762b8ab4a5740f1fe2d13b3bafcbb17da6f876896c6d65da4c2153e9247e00b7b9797ef49bd54fc31ca
+DIST aws-c-io-0.7.0.tar.gz 561762 BLAKE2B ffe8ac5de9fd5f57e7bc18e1d956f28567413d34ec23a7d0869065718039b1ab56aeae82fd8e24bf77f7393df2c1140308195cd8a4c6ff06cbc7843ae62d76c8 SHA512 b858a5a14cfea86c39f96963c4238ca0f90339befcbd6480e6353719d9846079764f8b42fbdc0cec2f99223bfe1c07fa2a014543fa3fe8a6357440e3cd1007f5
+EBUILD aws-c-io-0.7.0.ebuild 855 BLAKE2B f8b7518887efc711bc47e48c34fd9afcc282f6aac3215b4403a2fcf33b66c417b8933a75f0e138ffdbffb8f3872d6d9ebec4a6fdf9153fe9159e478bade0fc37 SHA512 9d91f7b6fdf41998bb50bb20f74d8b41156a6c34899dc8cbd778a119beff30b24fe5f504a639c1fc87864dd80235cd540f4b5214b6083e7f053ad6f369eabf9b
+MISC metadata.xml 1050 BLAKE2B 81eed64eeea9f2ee78bc14873e81e36830b5793c12a7f2d622f3bfde5ac76c16042f4f3284c4d5519f0ae168df6e155d0a330bf553b63f8a022279056d146ba5 SHA512 9debb68b6e98f34b357ea91a42b7ea772cbf2db76c222373c39a717327f03fb30d47b1e01157b171d97caa964122e5771d18855065efd2e6cf6c29207ac9a040
diff --git a/dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild b/dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild
new file mode 100644
index 000000000000..e3fbefde1310
--- /dev/null
+++ b/dev-libs/aws-c-io/aws-c-io-0.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="AWS SDK for C module, handles IO and TLS work for application protocols"
+HOMEPAGE="https://github.com/awslabs/aws-c-io"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ || (
+ >dev-util/cmake-3.19.1
+ <dev-util/cmake-3.19.0
+ )
+"
+
+DEPEND="
+ >=dev-libs/aws-c-cal-0.4.5:=[static-libs=]
+ >=dev-libs/aws-c-common-0.4.62:=[static-libs=]
+ >=dev-libs/s2n-0.10.21:=[static-libs=]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-prefix.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch b/dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch
new file mode 100644
index 000000000000..39cab922b3d9
--- /dev/null
+++ b/dev-libs/aws-c-io/files/aws-c-io-0.7.0-cmake-prefix.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,7 @@ elseif(NOT DEFINED CMAKE_INSTALL_LIBDIR)
+ endif()
+
+ # This is required in order to append /lib/cmake to each element in CMAKE_PREFIX_PATH
+-set(AWS_MODULE_DIR "/${CMAKE_INSTALL_LIBDIR}/cmake")
++set(AWS_MODULE_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/cmake")
+ string(REPLACE ";" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
+ # Append that generated list to the module search path
+ list(APPEND CMAKE_MODULE_PATH ${AWS_MODULE_PATH})
+
diff --git a/dev-libs/aws-c-io/metadata.xml b/dev-libs/aws-c-io/metadata.xml
new file mode 100644
index 000000000000..6e6c8ed7af38
--- /dev/null
+++ b/dev-libs/aws-c-io/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sven.eden@prydeworx.com</email>
+ <name>Sven Eden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+This is a module for the AWS SDK for C. It handles all IO and TLS work for application protocols.
+
+aws-c-io is an event driven framework for implementing application protocols. It is built on top of cross-platform
+abstractions that allow you as a developer to think only about the state machine and API for your protocols. A typical
+use-case would be to write something like Http on top of asynchronous-io with TLS already baked in. All of the platform
+and security concerns are already handled for you.
+
+It is designed to be light-weight, fast, portable, and flexible for multiple domain use-cases such as: embedded,
+server, client, and mobile.
+ </longdescription>
+</pkgmetadata>