summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild')
-rw-r--r--dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild b/dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..3bae4a9f0357
--- /dev/null
+++ b/dev-libs/aws-c-io/aws-c-io-0.7.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="AWS SDK for C module, handles IO and TLS work for application protocols"
+HOMEPAGE="https://github.com/awslabs/aws-c-io"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ || (
+ >dev-util/cmake-3.19.1
+ <dev-util/cmake-3.19.0
+ )
+"
+
+DEPEND="
+ >=dev-libs/aws-c-cal-0.4.5:=[static-libs=]
+ >=dev-libs/aws-c-common-0.4.62:=[static-libs=]
+ >=dev-libs/s2n-0.10.21:=[static-libs=]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-prefix.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ if use test; then
+ # (#759802) Due to network sandboxing of portage, internet connectivity
+ # tests will always fail. If you need a USE flag, because you want/need
+ # to perform these tests manually, please open a bug report for it.
+ mycmakeargs+=(
+ -DENABLE_NET_TESTS=OFF
+ )
+ fi
+
+ cmake_src_configure
+}