summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-event-stream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/aws-c-event-stream
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/aws-c-event-stream')
-rw-r--r--dev-libs/aws-c-event-stream/Manifest2
-rw-r--r--dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.7.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/aws-c-event-stream/Manifest b/dev-libs/aws-c-event-stream/Manifest
index 7bfce63b3ae6..497fdf3500d2 100644
--- a/dev-libs/aws-c-event-stream/Manifest
+++ b/dev-libs/aws-c-event-stream/Manifest
@@ -1,4 +1,6 @@
AUX 0.1.3-add_missing_cmake_install_prefix.patch 566 BLAKE2B 1e638a3fc81c27addf3fba53173584b379b271a357246f448d5df0dd34dbcea42f698c4e5be87937070d5274940e25c1dc893c2af621b999405925cd57471c70 SHA512 872305633d8f3129280d3252632dbc07d24ee666f236f02e568e27153dd69657a2cdfdb2d594d9a86816f09923fba5b0e9cb2bd3eb0198b2a9077e02082ff54a
DIST aws-c-event-stream-0.2.5.tar.gz 61949 BLAKE2B baebd87a916fb8440db56afa2b97bd02229d70e00b55c40a17a2f467ad683422a6c6747aa698adce5272a03ced3fe6957d8cc62040d8080d3ed95409d8182851 SHA512 1421d608d8a5cfa5ec5df3bd905aab9ce9abc913461569a99b895c8415e50305aca0be3595bd4f3ed74cb52cc0e342354d211531066fdde60e14dd60e5629239
+DIST aws-c-event-stream-0.2.7.tar.gz 63942 BLAKE2B 751199efa1889861b647ca2f59f4a323961aedb9184d8c1293ff8a32096bb6e22de43eb2afbe9eb433f43e07ef8be251c815cfd897eb81cf2041e5f7be230ead SHA512 3ecc9fd80cd37d87df34948a7d7ca344a7b5ff2298e5ecc568d945830f8f8cd88721e0d2c4d11dee06af87e14b9ff13c8f13b8abfee74826ae72c8a280109440
EBUILD aws-c-event-stream-0.2.5-r1.ebuild 1174 BLAKE2B d1813d2370c9599f5993a8a58620c8ff54f8c2eb8002071cbef77f089a845bb480348ff93e6e6e7feff790e78c795df320afae69c2f691788599f3d7ec5186f1 SHA512 f85b498448cb87d87bb4898f3c3218fd2d40a8ad46d21e80600c1c09319dda0c4944a84f0f18942297d3dfdac0b2da9d1d1965b89aec2c510d0e9f2466d2ca1d
+EBUILD aws-c-event-stream-0.2.7.ebuild 1101 BLAKE2B d3664088da4f06b2a33063618b8103fbc05634e8473c206aa3f5d84a6cd60bf4980b308a13731154f028a9a717112508a497472952c0767a9cc8ea5154dcb588 SHA512 6da822f7e508cb1bc0530079ed24fbe53020831c4212d5d96da4e08f07f64e923b208bbc999a195759d003e1304a3790c2bdc52d02a39c08dce78e467d69ef00
MISC metadata.xml 395 BLAKE2B 37b634fd59971e5e551280f9fca50f9b5a38b87f4fb0f1460ff3dd68ca858d80d5033630d1826cdf6f2dd7eac03422d81cca0abc58b057b2cfa1bf3d1437979a SHA512 498484f9a669cd21f6ae7e97b677618c745beed5ae28c78547a2c402869c444b2eba458c6516bca0fd06dee28eea39fb34a5c3a655b9fccc055a8bad078dd7cd
diff --git a/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.7.ebuild b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.7.ebuild
new file mode 100644
index 000000000000..557f3a34b074
--- /dev/null
+++ b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C99 implementation of the vnd.amazon.eventstream content-type"
+HOMEPAGE="https://github.com/awslabs/aws-c-event-stream"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/aws-c-common-0.5.2:=[static-libs=]
+ >=dev-libs/aws-c-io-0.9.2:=[static-libs=]
+ >=dev-libs/aws-checksums-0.1.10:=[static-libs=]
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.1.3-add_missing_cmake_install_prefix.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ if use test; then
+ # (#760585) Due to network sandboxing of portage, internet connectivity
+ # tests will always fail. If you need a USE flag, because you want/need
+ # to perform these tests manually, please open a bug report for it.
+ mycmakeargs+=(
+ -DENABLE_NET_TESTS=OFF
+ )
+ fi
+
+ cmake_src_configure
+}