summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild')
-rw-r--r--dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..8aada917d7df
--- /dev/null
+++ b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.2.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C99 implementation of the vnd.amazon.eventstream content-type"
+HOMEPAGE="https://github.com/awslabs/aws-c-event-stream"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ || (
+ >dev-util/cmake-3.19.1
+ <dev-util/cmake-3.19.0
+ )
+"
+
+DEPEND="
+ >=dev-libs/aws-c-common-0.4.62:=[static-libs=]
+ >=dev-libs/aws-c-io-0.7.0:=[static-libs=]
+ >=dev-libs/aws-checksums-0.1.10:=[static-libs=]
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.1.3-add_missing_cmake_install_prefix.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}