summaryrefslogtreecommitdiff
path: root/dev-libs/atk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/atk
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/Manifest5
-rw-r--r--dev-libs/atk/atk-2.22.0.ebuild52
-rw-r--r--dev-libs/atk/atk-2.24.0.ebuild52
-rw-r--r--dev-libs/atk/metadata.xml8
4 files changed, 117 insertions, 0 deletions
diff --git a/dev-libs/atk/Manifest b/dev-libs/atk/Manifest
new file mode 100644
index 000000000000..5035709ac752
--- /dev/null
+++ b/dev-libs/atk/Manifest
@@ -0,0 +1,5 @@
+DIST atk-2.22.0.tar.xz 745572 BLAKE2B 4764a6044446de8e08b54c47400727268ca68e676aa36c01877f2b3f973614a40f209406b649f0e96f4a5b75be883ce67ac3fbf20ac0c58adfbaf3509caac312 SHA512 af3f6197eb97de869ee706f19564449b02c1444c413e5418323e4bf4c8cf1d98c7c8baa25189f6879d63606d4bc75f33799cb901f4697c087e868bb9a5643cba
+DIST atk-2.24.0.tar.xz 748972 BLAKE2B f9db7e35322cf4a1df5171c812c83eb935ba44b0167b20ca9a951109c00911392a48db88fac02a12074de4d9f458656f946e8bb7611e1d11cc0de841986f8cc7 SHA512 3ae0a4d5f28d5619d465135c685161f690732053bcb70a47669c951fbf389b5d2ccc5c7c73d4ee8c5a3b2df14e2f5b082e812a215f10a79b27b412d077f5e962
+EBUILD atk-2.22.0.ebuild 1428 BLAKE2B 09fcdbf9c0360b4028be8ffca418f4e83a839fade16e3d1a67f34b9a43ae87ab6f4b44e6f5c363f6fef074ea2d822ed3bb14b58c656dc294426c82d968db98c8 SHA512 64ed9a17da2175f795a0abce2ef28d246f242990962fef66002fab227d5553bc89ca4dbdb779c2a29a1c59e34f3f04260f8669405a9cdd166b76cf2dd9ae6652
+EBUILD atk-2.24.0.ebuild 1429 BLAKE2B 6ebee4e0388171527cdf514ca1c38725aeeb7fe27718cc7237ad2d31ff5014bdc2916d6086f35b27957c4595a6ad4e2373d100508ff6b4195ec695eb498520ed SHA512 31460d1d7f2404e573b2a3d6ebeceb20e47a9126567db60060551c59c1da0619711e0cedc1489b5e2557c36283d165df78a72185c12d5ca0176358b279ea8fdd
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/atk/atk-2.22.0.ebuild b/dev-libs/atk/atk-2.22.0.ebuild
new file mode 100644
index 000000000000..96f8672f4347
--- /dev/null
+++ b/dev-libs/atk/atk-2.22.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=sys-devel/gettext-0.19.2 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Building out of sources fails, https://bugzilla.gnome.org/show_bug.cgi?id=752507
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+# ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+# if multilib_is_native_abi; then
+# ln -s "${S}"/docs/html docs/html || die
+# fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/atk/atk-2.24.0.ebuild b/dev-libs/atk/atk-2.24.0.ebuild
new file mode 100644
index 000000000000..3d011579c0cd
--- /dev/null
+++ b/dev-libs/atk/atk-2.24.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=sys-devel/gettext-0.19.2 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Building out of sources fails, https://bugzilla.gnome.org/show_bug.cgi?id=752507
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+# ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+# if multilib_is_native_abi; then
+# ln -s "${S}"/docs/html docs/html || die
+# fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/atk/metadata.xml b/dev-libs/atk/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-libs/atk/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>