summaryrefslogtreecommitdiff
path: root/dev-libs/argtable/argtable-2.13-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
commit12de738b83927a4b71c3ad067edbb6279d15b368 (patch)
tree87b2ef3927262a0aba7a923512909bdbadd71b8b /dev-libs/argtable/argtable-2.13-r4.ebuild
parent7b7a5ff63901698b7b993201e07bcaf8d0e5db2f (diff)
gentoo auto-resync : 09:05:2023 - 23:42:14
Diffstat (limited to 'dev-libs/argtable/argtable-2.13-r4.ebuild')
-rw-r--r--dev-libs/argtable/argtable-2.13-r4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/argtable/argtable-2.13-r4.ebuild b/dev-libs/argtable/argtable-2.13-r4.ebuild
new file mode 100644
index 000000000000..f5b108d4161e
--- /dev/null
+++ b/dev-libs/argtable/argtable-2.13-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_rs 1 '-')"
+MY_P=${PN}${MY_PV}
+
+DESCRIPTION="An ANSI C library for parsing GNU-style command-line options with minimal fuss"
+HOMEPAGE="https://argtable.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc debug examples static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.13-Fix-implicit-function-declaration.patch
+ "${FILESDIR}"/${PN}-2.13-Fix-undeclared-library-function.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ rm -rf "${ED}"/usr/share/doc/${PF}/
+
+ if use doc ; then
+ cd "${S}"/doc || die
+ dodoc *.pdf *.ps
+ docinto html
+ dodoc *.html *.gif
+ fi
+
+ if use examples ; then
+ cd "${S}"/example || die
+ docinto examples
+ dodoc Makefile *.[ch] README.txt
+ fi
+
+ find "${ED}" -name "*.la" -delete || die "failed to delete .la files"
+}