summaryrefslogtreecommitdiff
path: root/dev-libs/appstream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-libs/appstream
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-libs/appstream')
-rw-r--r--dev-libs/appstream/Manifest4
-rw-r--r--dev-libs/appstream/appstream-0.12.10.ebuild72
-rw-r--r--dev-libs/appstream/appstream-0.12.9.ebuild4
3 files changed, 77 insertions, 3 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index 182c4a10dfba..f6c7d5a0af37 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,5 +1,7 @@
+DIST AppStream-0.12.10.tar.xz 2045744 BLAKE2B fd8f96bd0b829e73bbbb5ae725feaf8f1275f2ed4a50ad107fddc52cdfd7d7c2e382235fc322513cdfe000789505e7b9998bb4e601e223d673ee65c0fbb55c25 SHA512 5cd7da7adbd035947bde6a6d7655dc2f7c1be25cef102e51ef88e8f684a83b196a41b440edaabdd89da69a9117a26dad30e548b86b50f324f0ba70eef95a6060
DIST AppStream-0.12.7.tar.xz 1958948 BLAKE2B 51a70395e4801ceeb3e97ac081f4c45be242cca14728f8efc5eec0d4b3cfa4cc9fab9ef7429c18e9bbb0dedb693a847258be1b11491155658a6ffa2a28358e35 SHA512 53ca7ebde3fcd345a895527da2ac5d829a09f25d28836a867b500282fba3465bde657cd75a4030cb831022f7a0d9f50aadb36078d62924e4d0edad6bfe3c5561
DIST AppStream-0.12.9.tar.xz 2023312 BLAKE2B aa5de7936909be54401e4df80363c9b59ad60dc29b3d02ef1ed8203dd480dfb4222816cde5ea6e469039448684142afc028275e619665f15cef99af6745d80e8 SHA512 af3d5e7885ee09fb6ef9ea0a5c2386141736166ce42912e618f1ee04f2b28866b27c7c5e326221574eb78933b32de8db9f76023bf54e528aded1607e5130992e
+EBUILD appstream-0.12.10.ebuild 1695 BLAKE2B 4ebb95eca1abb10ee9ca9f9dbd6ab2c766b1718ffd7f5fa1e08354451493cab0ad9a2a19866582f9c4525dd077c4cd81987c0040990991b41f152ce038877a99 SHA512 e46cf958e89a2f7247f24d36d8baf056b2ce0dc0bba00f0c87d3df7997b3100807c6c82124cff92a8570b17b859486f3e948662941c5ca1cec0720a296954c5a
EBUILD appstream-0.12.7.ebuild 1619 BLAKE2B 0355409cb6ed3d49aba5deee05dddb87dd000b45427a472a1ca39a9c887567ef7f26cbf777eb9b9a6ec50e90b5544c1c607636ec22f8227ac5f087e7b2d0bcec SHA512 90a0ab33c5cf51b48c4297da10e26765b18a55bf5d2b18c051d6119ef10bc94d6470cb708d3105af39349ec63de90c1f03883544dcecad6853bce85f09b9b4fb
-EBUILD appstream-0.12.9.ebuild 1651 BLAKE2B 094685c556ba8196ff701c0a76ea25ad870cc3edd8543f6b9cadd5616af3f4c607895fe1ea74654a7d72acc6aea8c194aaf18c8ae34f402069cd036f36923e95 SHA512 7917b204126a71e1c1ab4cebf4b191bcab86786fb2689e8ef6ed767910daa776201eaf1710998959e8fe7f4c0c0020fc7192caa407fe56c0386c23a3f46173a6
+EBUILD appstream-0.12.9.ebuild 1658 BLAKE2B 89cfed791e1f670d058161b502fac472bbdbd65d72f6a4792545b1b5489af15c3d9d12410a98f4a9b9671d00f750d845f4ac319aa4991243008a561f91b7d5ec SHA512 ea8d78f803e995d52633dc1b2ab5f3f140feb446141cbe89081175463a2978575da29e46c3bac4c51f1e713f8c07995692ccafd02096e150c65488b2904fa225
MISC metadata.xml 399 BLAKE2B 433fcfbb840f3efc4130de1a4b9a18ce3b1762363bfa67d994a063098da0397b6776a6154250ad5a35a4960241234f2ba3dc2464b760cf19cbb680590d559049 SHA512 1f81f3603fc34a3dbeb570fe83ed2ff97e4ea2391cda7d7ceef017624a8498052cda4a21dee1f6b8eb41407998dfcecd765bde556837d00b13caaa41989f934f
diff --git a/dev-libs/appstream/appstream-0.12.10.ebuild b/dev-libs/appstream/appstream-0.12.10.ebuild
new file mode 100644
index 000000000000..4d3a31bbb3b3
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.12.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ SRC_URI="https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/AppStream-${PV}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt doc +introspection qt5 test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ doc? ( app-text/docbook-xml-dtd:4.5 )
+ test? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+ dev-db/lmdb:=
+ >=dev-libs/glib-2.58:2
+ dev-libs/libxml2:2
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer
+ >=net-libs/libsoup-2.56:2.4
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( qt5? ( dev-qt/qttest:5 ) )
+"
+
+src_prepare() {
+ default
+ sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+ if ! use test; then
+ sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local emesonargs=(
+ -Dapidocs=false
+ -Ddocs=false
+ -Dmaintainer=false
+ -Dstemming=true
+ -Dvapi=false
+ -Dapt-support=$(usex apt true false)
+ -Dinstall-docs=$(usex doc true false)
+ -Dgir=$(usex introspection true false)
+ -Dqt=$(usex qt5 true false)
+ )
+
+ meson_src_configure
+}
diff --git a/dev-libs/appstream/appstream-0.12.9.ebuild b/dev-libs/appstream/appstream-0.12.9.ebuild
index 90432b992ef2..cdde8b212f70 100644
--- a/dev-libs/appstream/appstream-0.12.9.ebuild
+++ b/dev-libs/appstream/appstream-0.12.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/ximion/${PN}"
else
SRC_URI="https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
S="${WORKDIR}/AppStream-${PV}"
fi