summaryrefslogtreecommitdiff
path: root/dev-libs/appstream/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-23 13:50:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-23 13:50:55 +0000
commited8299fef4175104e66b734cfc0482770614f398 (patch)
treed701a504c6fca51a0182f6ba21f16af855ee24b4 /dev-libs/appstream/files
parent4035d30ea0ada73d992bb7d583c0b37a053714fe (diff)
gentoo auto-resync : 23:12:2023 - 13:50:55
Diffstat (limited to 'dev-libs/appstream/files')
-rw-r--r--dev-libs/appstream/files/appstream-1.0.0-disable-Werror-flags.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/appstream/files/appstream-1.0.0-disable-Werror-flags.patch b/dev-libs/appstream/files/appstream-1.0.0-disable-Werror-flags.patch
new file mode 100644
index 000000000000..309d365c28ec
--- /dev/null
+++ b/dev-libs/appstream/files/appstream-1.0.0-disable-Werror-flags.patch
@@ -0,0 +1,47 @@
+--- a/meson.build
++++ b/meson.build
+@@ -90,44 +90,6 @@
+ endif
+ endif
+
+-# a few compiler warning flags we always want enabled
+-add_project_arguments(
+- cc.get_supported_arguments([
+- '-Werror=shadow',
+- '-Werror=empty-body',
+- '-Werror=strict-prototypes',
+- '-Werror=missing-prototypes',
+- '-Werror=implicit-function-declaration',
+- '-Werror=pointer-arith',
+- '-Werror=missing-declarations',
+- '-Werror=return-type',
+- '-Werror=int-conversion',
+- '-Werror=incompatible-pointer-types',
+- '-Werror=misleading-indentation',
+- '-Werror=missing-include-dirs',
+- '-Werror=declaration-after-statement',
+- '-Werror=format-security',
+-
+- '-Wno-missing-field-initializers',
+- '-Wno-error=missing-field-initializers',
+- '-Wno-unused-parameter',
+- '-Wno-error=unused-parameter',
+- ]),
+- language: 'c'
+-)
+-add_project_arguments(
+- '-Wno-unused-parameter',
+- '-Werror=empty-body',
+- '-Werror=pointer-arith',
+- '-Werror=init-self',
+- '-Werror=missing-declarations',
+- '-Werror=return-type',
+- '-Werror=misleading-indentation',
+- '-Werror=format-security',
+-
+- language: 'cpp'
+-)
+-
+ # Vendor extensions in system headers
+ if host_machine.system() != 'netbsd'
+ # on NetBSD, defining POSIX_C_SOURCE *removes* non-POSIX symbols from namespace,