summaryrefslogtreecommitdiff
path: root/dev-libs/appstream/appstream-0.11.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/appstream/appstream-0.11.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/appstream/appstream-0.11.5.ebuild')
-rw-r--r--dev-libs/appstream/appstream-0.11.5.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/appstream/appstream-0.11.5.ebuild b/dev-libs/appstream/appstream-0.11.5.ebuild
new file mode 100644
index 000000000000..bf4e52ace68b
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.11.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson xdg-utils
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ inherit eapi7-ver
+ MY_PV="$(ver_rs 0- '_')"
+ MY_P="APPSTREAM_${MY_PV}"
+ SRC_URI="https://github.com/ximion/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_P}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt doc qt5 test"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/libxml2:2
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ dev-util/itstool
+ >=dev-util/meson-0.42.0
+ sys-devel/gettext
+ test? (
+ qt5? ( dev-qt/qttest:5 )
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-meson-po.patch" )
+
+src_configure() {
+ xdg_environment_reset
+
+ local emesonargs=(
+ -Denable-docs=false
+ -Denable-maintainer=false
+ -Denable-stemming=true
+ -Denable-vapi=false
+ -Denable-apt-support=$(usex apt true false)
+ -Denable-apidocs=$(usex doc true false)
+ -Denable-qt=$(usex qt5 true false)
+ )
+
+ meson_src_configure
+}