summaryrefslogtreecommitdiff
path: root/dev-libs/appstream-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-06 21:20:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-06 21:20:35 +0000
commitb6ed1e2a15cd8b0ad5c573cbfee3576fa5ee29a4 (patch)
tree1ec8ec6766a5f19885797eec219ed98b78be4b7d /dev-libs/appstream-glib
parent3d013ccac70a281416dccbb6757f76818222cbba (diff)
gentoo auto-resync : 06:11:2022 - 21:20:35
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/Manifest2
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.8.2.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index 08ced3c3a9f9..465e895ea549 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1,3 +1,5 @@
DIST appstream-glib-0.8.1.tar.xz 2320596 BLAKE2B de8d68c541cd6700fff0bc22a71d59510ccf584ac1380e2aed3e5aa122825cb3087d65b42ac1dc35acbd4b171382d9560545cdeaffa9d6bda721784444bf7a36 SHA512 32462a32ea25c945abb8d9084af1c84850f264b3a2136c6f54444e0168acf0d74ee450f8cbf483a504e417dc29b85a2e9bbc0a5bb8a217296eccacaa02db5ef5
+DIST appstream-glib-0.8.2.tar.xz 2320880 BLAKE2B 6c3c90298ae8bf362caea8c46643afaaab0bb0071271f5244eeca9356ed96a6a956c1b2ffa4a8500201e4bc494a54a15b3db4937b81c6f5f8b80f83299ac58ee SHA512 c9c21049ab43f5da8595aa07a3c2e097163a05b5e0fc030e4e3326136cd18127f04ad9edf08c12aea823b89048b43808cc60759cc26fcf2541cd9c1acbb29e28
EBUILD appstream-glib-0.8.1.ebuild 1605 BLAKE2B d55cffcb667106deac403387b10d8c2e73d24edebe82fe82f660d523956488cd0f1ec4463ad502f8b2650dd0ed344bad96c1d79a16edd531284416111ca3ab84 SHA512 530ce1b46428e187db62432028f987d17388c9d025051fd77c6ba27eb39a86aaa74f79dce7a9065440f272b1170cf21276ca31472dbb0e5f07999da58b42d778
+EBUILD appstream-glib-0.8.2.ebuild 1612 BLAKE2B 63ae73dd8d322cecb441bb52971e23ee91bdd179d324de99191f561ea2bbb06fad6ff668d8917705b9761920e2fde538fea620ecfd6ec6797bc6ba0d88b1b845 SHA512 dd5e22b14be599c4abe1f1a1d0d565ef4749865cc9c88bc3a6a24b3be1527273b2993bf3a2dd55f8fc89908875b4eea40d85c258198412b4f0344f983a232094
MISC metadata.xml 518 BLAKE2B 86626ba74aa4910c2c6148a1ccfbfa7239ee49dbd2ae570f033226a5b145eecdfe0fbb89381a33a7bd03f98176a009ac5d6a67a725b221f2a1005ae17de4907a SHA512 8dc91556a745b2fa694171daf8080a986a42040ce088c6c320a6287660f288522b77d701fae78bf1b16f3d9e0d20b03a8b27c849e561b6b48c5529c71bcce554
diff --git a/dev-libs/appstream-glib/appstream-glib-0.8.2.ebuild b/dev-libs/appstream-glib/appstream-glib-0.8.2.ebuild
new file mode 100644
index 000000000000..27c3f6959920
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.8.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/ https://github.com/hughsie/appstream-glib"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk-doc fonts +introspection stemmer"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ sys-apps/util-linux
+ app-arch/libarchive:=
+ >=net-misc/curl-7.56.0
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+ fonts? (
+ x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2
+ )
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ stemmer? ( dev-libs/snowball-stemmer:= )
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ $(meson_use fonts)
+ $(meson_use stemmer)
+ -Dman=true
+ $(meson_use gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}