summaryrefslogtreecommitdiff
path: root/dev-libs/antlr-c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-libs/antlr-c
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-libs/antlr-c')
-rw-r--r--dev-libs/antlr-c/Manifest2
-rw-r--r--dev-libs/antlr-c/antlr-c-3.5.2-r2.ebuild (renamed from dev-libs/antlr-c/antlr-c-3.5.2-r1.ebuild)27
2 files changed, 12 insertions, 17 deletions
diff --git a/dev-libs/antlr-c/Manifest b/dev-libs/antlr-c/Manifest
index 6e936b1e0b39..ef8ea35092e0 100644
--- a/dev-libs/antlr-c/Manifest
+++ b/dev-libs/antlr-c/Manifest
@@ -1,4 +1,4 @@
AUX 3.5-cflags.patch 423 BLAKE2B 1605eb4dbc47bdd9f54699a0fe0f0bdc54d419b68d4a99be11c55a654d3167422560e4edbdd59515b65f52d9a7785b103baa9e1e6742be8f9c40eb1985c6cf5e SHA512 fbabfd7db5d373646b873a5b56c6153b39c5287518ced27c4857aa91947998cfe009db143995d8fe93750068f615092edb647ea2a2ededa7a7997e6c741fb638
DIST antlr-3.5.2.tar.gz 6927126 BLAKE2B 1907229549434dfea6ef1fa915137a2f733bd61f0a40aacb131689df619d1c92e125453ec3d1febc5d92da1841ffbde060af196cff1ca8fb6f4684600375e161 SHA512 e2a0520093fb2a77dcd9d44f26a9fdd612dceaffb398c53b2b8cd29f4630830647ede29e8dd55b434cb2c165b0fd1d77968ec6e6de0798f14d9cdfd9e6fccd99
-EBUILD antlr-c-3.5.2-r1.ebuild 1346 BLAKE2B 0f5514635fddb6cdc833b4e904b846f9a308f0af23bc7fc99deeefcb29cc4a742e9fbc9ac1fef1b23b5174c0755120c834eeeff5659ed2a8d546a029b0ed7fdb SHA512 744d8bf6a9ef64cc197f48369d76f4fb05a57ff25b421d42b0e5e4c6961bdd8b9b4ee4ba3885744a0e6a202a104a8f4ac34675bbb1dc6e6b5532afb0a0708c5a
+EBUILD antlr-c-3.5.2-r2.ebuild 1128 BLAKE2B b8955b16713b8d6572fb8b9ba33d57feea9186e678a4c833ff033300375693b50d615782a59c385eaf42e719ab93ec42ca90ea5dcd157a5026d3b54f1c25dfa2 SHA512 2a85ef45ac7dbe1d446b2949fece7bf5d774ab1033c909bc377e1749082a262a24b3fba40f2dcc02516698909aa5cae1b76cd4969d924ae2ae1ab4414e0394ba
MISC metadata.xml 337 BLAKE2B e7536e66d5b8bd250838b00b81d494a800134f65625bb11c598f0ed39b4832a962c0894220b02522300c9930e1980bfccb8c70a176d87c2274d6042a7fe832f2 SHA512 1ef902a5485a4156a7994a84820df004fc0d76e6a82da4abd4962954dfa33c74b69c694cf74dd94b9a8ab584746a6ceaaafecc566342faa3764cdd6144b08a3a
diff --git a/dev-libs/antlr-c/antlr-c-3.5.2-r1.ebuild b/dev-libs/antlr-c/antlr-c-3.5.2-r2.ebuild
index e0b7a34e56fa..f7a8a0295cdd 100644
--- a/dev-libs/antlr-c/antlr-c-3.5.2-r1.ebuild
+++ b/dev-libs/antlr-c/antlr-c-3.5.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
MY_PN="${PN%-c}"
DESCRIPTION="The ANTLR3 C Runtime"
@@ -19,20 +19,16 @@ IUSE="debug debugger doc"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
PATCHES=( "${FILESDIR}/3.5-cflags.patch" )
-MULTILIB_WRAPPED_HEADERS=( /usr/include/antlr3config.h )
-DOCS=( AUTHORS ChangeLog NEWS README )
src_prepare() {
default
+
sed -i '/^QUIET/s/NO/YES/' doxyfile || die
eautoreconf
- multilib_copy_sources
}
-multilib_src_configure() {
+src_configure() {
local econfargs=(
- --enable-shared
- --disable-static
$(use_enable debug debuginfo)
$(use_enable debugger antlrdebug)
)
@@ -42,24 +38,23 @@ multilib_src_configure() {
*) econfargs+=( --disable-64bit ) ;;
esac
- econf "${econfargs[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${econfargs[@]}"
}
src_compile() {
- multilib-minimal_src_compile
+ default
- if use doc; then
+ if use doc ; then
einfo "Generating API documentation ..."
- cd "${S}" || die
doxygen -u doxyfile || die
doxygen doxyfile || die
+
+ HTML_DOCS=( "${S}"/api/ )
fi
}
src_install() {
- use doc && HTML_DOCS=( "${S}/api/" )
-
- multilib-minimal_src_install
+ default
find "${ED}" -name '*.la' -delete || die
}