summaryrefslogtreecommitdiff
path: root/dev-libs/aml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-libs/aml
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-libs/aml')
-rw-r--r--dev-libs/aml/Manifest4
-rw-r--r--dev-libs/aml/aml-0.2.0.ebuild28
-rw-r--r--dev-libs/aml/aml-9999.ebuild28
-rw-r--r--dev-libs/aml/metadata.xml15
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/aml/Manifest b/dev-libs/aml/Manifest
new file mode 100644
index 000000000000..afb6ea1d3fe6
--- /dev/null
+++ b/dev-libs/aml/Manifest
@@ -0,0 +1,4 @@
+DIST aml-0.2.0.tar.gz 20358 BLAKE2B 4be63726ea9069cbfe36fbf04e3a0b2229066d7df039aea1a41fdca27700d012fda9eda348115f8c0ef9d3f201640123722d0b96bc7b171841d920357a292152 SHA512 196cd891fdbaad47340d8b4ca9eb62a7f9e6b0969ae9ad744a3c9ea110a532691d53a1e39fde583bad0f8fdae4b51c3a4243bbdab65e952e5fc79ceb6efc3262
+EBUILD aml-0.2.0.ebuild 535 BLAKE2B 3ab2c148d97b733405e6ae622681e48834944564f0fcb7306337938440205765c1c45d16e9dfbddcd9f9dc85d99a0c093090fd4d45e3647e6b3f869a673774be SHA512 ee09a25d9331fe35d9f867780b05aadc03f18fa53ebb70fd69f6782e187dc7829f1112366b198fdbfb810147de3498ca3c4a3570caab942551f506a0925b018e
+EBUILD aml-9999.ebuild 535 BLAKE2B 3ab2c148d97b733405e6ae622681e48834944564f0fcb7306337938440205765c1c45d16e9dfbddcd9f9dc85d99a0c093090fd4d45e3647e6b3f869a673774be SHA512 ee09a25d9331fe35d9f867780b05aadc03f18fa53ebb70fd69f6782e187dc7829f1112366b198fdbfb810147de3498ca3c4a3570caab942551f506a0925b018e
+MISC metadata.xml 432 BLAKE2B 5b98c6e8af0056d63f5ff10ebb335363aa9b6da251232aadc738cf7156ddb15727893eedb55b590caa9f1f019fe28f1651708bc1b6c43ae2cead800047c3949e SHA512 81e7bc6d24d13b710c844244b70d139128ffa73661856882a5493e26e12bad78e87f494ef9ba838635087b3f5fffebb375df2468af4a9985fd9ebff876178392
diff --git a/dev-libs/aml/aml-0.2.0.ebuild b/dev-libs/aml/aml-0.2.0.ebuild
new file mode 100644
index 000000000000..db62c0b53724
--- /dev/null
+++ b/dev-libs/aml/aml-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/aml/aml-9999.ebuild b/dev-libs/aml/aml-9999.ebuild
new file mode 100644
index 000000000000..db62c0b53724
--- /dev/null
+++ b/dev-libs/aml/aml-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="event timer executor loop"
+HOMEPAGE="https://github.com/any1/aml/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/aml/metadata.xml b/dev-libs/aml/metadata.xml
new file mode 100644
index 000000000000..9e2438fd5155
--- /dev/null
+++ b/dev-libs/aml/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="examples">Build and install examples</flag>
+ </use>
+</pkgmetadata>